Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I go to various sites I believe Firefox is informing the site that I am some other language which causes certain headers to look like they should be in a different language. To me they look like latin characters or something; however, my intuition tells me that if i had the correct charset it would show some other language.

Furthermore, on one occasion when i went to: groups.google.com/group/cake-php Google forwarded me to: http://groups.google.ch/group/cake-php

Even when I correct it to the .com the header area reads in that odd character set.

A better example is CakePHP.org... When I go there every header, including the main header reads in this odd charset, while the other text reads normally.

My language in ff is set to english en/US and the only other language i have installed is en...

My charset is set to unicode UTF-8...

This doesn't happen in chrome or ie so it is not a machine or IP thing.

I have a feeling this may have started when i was messing with translations on facebook.

Thanks!!!

share|improve this question
    
Does this happen with any other browser or application on the computer? –  Hello71 Jul 5 '10 at 19:16
    
nope it is only firefox. –  Parris Jul 5 '10 at 19:31
add comment

4 Answers

Check in Tools / Options / Content / Languages Choose, whether you have some strange languages listed.

Ensure that only the languages you need are listed.

EDIT

Once the languages are defined correctly, then next stop is to start FF with the Mozilla Firefox (Safe Mode) shortcut. If this fixes the problem, then it's some add-on that's causing the problem, which you should locate and uninstall.

If the problem still exists, then strong measures may be needed. Uninstall FF, clean-out the installation directory and re-install.

If that doesn't help, the next tool to use would be a sledge-hammer.

share|improve this answer
    
just en-US and en as i said above –  Parris Jul 5 '10 at 19:32
    
@Parris: See my edit above. –  harrymc Jul 5 '10 at 19:59
add comment

You can check wether Firefox actually requests a different language, by viewing the HTTP Request header you are sending. This webpage show it to you. Look if accept-language has the correct value.

share|improve this answer
add comment
up vote 1 down vote accepted

Sooo, once I upgraded to thunderbird it seems some setting went off and thunderbird also started experiencing the same issue. This occured while i was typing as well, but not always. I noticed that when the font was set to variable width instead of Helvetica/Arial everything was fine. I then decided to test "arial" alone and that worked fine, which led me to believe helvetica was the issue. I suppose it is not some correct font type and some how this causes things to appear in odd languages in FF only sometimes? In any case, I now force ff to display everything in arial rather than let websites choose fonts for me. It is sort of a workaround, but it seems to do the trick and I can live with it.

share|improve this answer
add comment

We have a set of proxy servers at work. One day the WPAD file got wonked up and sent all US users out through the CH proxy server, so many multilingual sites showed us a non-English page by default.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.