Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently installed TightVNC, and used it to access my desktop from my phone. When I did so, my desktop reported that Aero had been disabled due to an application being run that didn't support it. I now cannot re-enable Aero, despite having closed the TightVNC server (and indeed having rebooted a number of times since).

Windows 7 troubleshooting reports the following:

Close programs using mirror drivers

To allow Aero effects to be displayed, close any programs that use mirror drivers (a type of display driver), such as Windows Remote Assistance and Windows Live Mesh.

The troubleshooting system appears to attempt to automatically fix that, but fails.

I can see nothing in the task manager that obviously uses mirror drivers; in particular, I can see nothing that looks like TightVNC in there. Starting and exiting TightVNC makes no difference.

Google has turned up nothing that looks useful so far, either, although my Google-fu isn't great and I may just be searching for the wrong things.

There's another question that reports the same problem, caused by LogMeIn rather than TightVNC, but the solution listed there doesn't work—TightVNC doesn't install LogMeIn mirror drivers, for obvious reasons.

share|improve this question

3 Answers 3

Have you tried changing the appearance in the Personalization menu? Try changing your theme there, then restarting if the changes don't happen immediately. Another problem could have to do with the Windows evaluation and it can't tell if your desktop is able to run Aero. Try to re-evaluate your system performance in Computer > Properties.

I also found this section on how to force the Aero theme:

Force Enable Aero in Windows 7

  1. Click on Start and type regedit at run

  2. Now Navigate to the following registry key:

HKEY_CURRENT_USER\Software\Microsoft\Windows\DWM

  1. In the right details pane, create following Three DWORD (32-bit value) entry

UseMachineCheck, and set its value to 0.

Blur, and set its value to 0.

Animations, and set its value to 0.

  1. Close Regedit

  2. Click on Start and type CMD with administrative Priviliges

  3. Now type following command

Net Stop uxsms

Net Start uxsms

Above command will stop and start Desktop Window Manager Session Manager.

  1. Now you can turn on Aero by right clicking on desktop-> Personalize -> Select Windows Colors
share|improve this answer
    
    
I tried the personalization menu; there was nothing there, and the Windows evaluation was fine. I worked out the solution myself, anyway, and answered the question myself. –  me_and Jul 5 '10 at 20:51
up vote 0 down vote accepted

Worked it out myself, based on the answer I linked to in the question: in Windows Device Manager under Display adapters, disable "Mirage Driver".

Edit: Since this solved the problem, I'd mark it as "accepted". Seems I can't, though: apparently I can't accept my own answer to a question for 48 hours after posting it. Just in case anyone's wondering why the question's still listed as unanswered…

share|improve this answer
    
Ah, that makes sense. Good job. I'll remember this for next time. –  BioXhazard Jul 5 '10 at 21:04

This is a known problem in TightVNC. Some time ago I developed a fix and posted it here:

http://sourceforge.net/mailarchive/forum.php?thread_name=D7003C5C849B4A69A51DEB83DEECBAF9%40sevnotebook&forum_name=vnc-tight-devel

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.