Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

While typing in a text box in Google Chrome I can usually see which words I have spelt incorrectly as they are underlined by a wavy red line. If I right click I am then offered alternate spellings or I can 'Add to dictionary'.

This has stopped working on my home PC so every word is now highlighted. How can I correct this?

share|improve this question
    
Check Options > Under the Bonnet > Change Font... > Languages anything look off to you? – random Jul 5 '10 at 20:51
    
Looks normal to me, I have 'English (United Kingdom)' selected as both Spell checker language and Google Chrome language. Same settings as my laptop which works fine. – Swinders Jul 5 '10 at 21:00
    
Any extensions installed? – random Jul 7 '10 at 4:58
    
No extensions, think I have found a solution, will post details later today when I can get back on the PC that is having the problem to confirm. – Swinders Jul 7 '10 at 8:35
up vote 2 down vote accepted

It looks like this was caused by my web filtering software blocking the download of the dictionary file. When I opened it in a text editor (notepad++ in this case) I saw an html page with the title:

K9 Web Protection Alert: Category Blocked

The dictionary file is found at:

C:\Documents and Settings\<User name>\Local Settings\Application Data\Google\Chrome\Application\Dictionaries

Removing the file and unblocking software downloads allowed Chrome to re-download the dictionary file and spell check works again.

share|improve this answer

I changed the fonts and language to English (United Kingdom) for spell check and google chrome display. Works like a charm :)

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .