Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

i have a compaq presario m2000 and just recently installed ubuntu 9.1 on it. i have to be connected to the internet by wire because my wireless drivers arent working. i have tried everything i can think of. i tried the terminal command: sudo apt-get install b43-fwcutter, and that seams to work. i get the driver, and it says it is activated in the driver manager, but on the top of the manager, it says, "there are no proprietory drivers activated". my wireless light on my laptop comes on, so the wireless is on, but when i try to connect, it says that there is no wi-fi availible. i know that this is wrong because i could connect using windows xp last week. i have also tried the terminal command: sudo apt-get install bcmwl-kernel-source, and that works, until i reboot my system. i can connect to the wireless network, and when i turn off my computer, and turn it back on, it says that i dont even have a wireless card?! so the only way i have found is to reinstall the operating system and start over.

if anyone has any ideas, i am very willing to try them. please help me!

share|improve this question

migrated from stackoverflow.com Jul 6 '10 at 2:21

This question came from our site for professional and enthusiast programmers.

2 Answers 2

Can you please post the results of lspci?

Also, did you take a look at this guide?

http://ubuntuforums.org/showthread.php?t=185174&highlight=broadcom+dapper

share|improve this answer

It seams that you already installed new kernel with:

sudo apt-get install bcmwl-kernel-source

if it works with this kernel modules (cause to use the kernel itself you would need to restart the system) you should modify your grub.conf (boot config) to run the specified kernel.

Ubuntu makes people feel to comfortable ;) but did you try to recompile the kernel and include your wifi driver in it?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.