Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This question already has an answer here:

Because I program a lot on my personal machine, sometimes I have a lot of windows open with articles on blogs etc that I would like to keep open as I'm working in addition to VS etc. Rather than turn my comp off at night or put it into hibernation (shudder), I simply leave it in standby or just plain on.

The problem is, every once in a while, Windows Update performs an update and automatically restarts my comp, which makes me lose everything. Where is the setting to prevent this from happening?

share|improve this question

marked as duplicate by and31415, Fazer87, Breakthrough, Moses, Doktoro Reichard Jul 3 at 1:35

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
not a dupe... that's how to prevent the prompt... i want it to stop altogether –  Jason Jul 30 '09 at 22:34
1  
also, that is XP... that solution isn't available on Vista –  Jason Jul 30 '09 at 23:00
add comment

3 Answers

up vote 4 down vote accepted

This registry hack, mentioned in the previous answer, is the permanent solution to preventing the reboot in the Home (or any) edition of Windows.

Prevent Windows Update from Forcibly Rebooting Your Computer

alt text

share|improve this answer
    
i don't get the "WindowsUpdate" folder as an option... –  Jason Jul 30 '09 at 23:58
1  
Then create it. –  EvilChookie Jul 31 '09 at 0:22
    
Or just go to the link and download the registry patch. –  The How-To Geek Jul 31 '09 at 0:36
add comment

Possible Fix 1: This shows you the temp fix and a permanent registry fix.

http://www.howtogeek.com/howto/windows-vista/prevent-windows-update-from-forcibly-rebooting-your-computer/

Possible Fix 2: If you follow the link after it mention vista home users, you can do this:

http://www.howtogeek.com/howto/uncategorized/temporarily-disable-windows-updates-automatic-reboot-in-vista/

The second part mentions shutting down the windows update service so it cannot run while the machine is on. The only catch is it will start back up once you restart. When you run cmd.exe, make sure to right-click the icon for cmd.exe and "Run As..." an Administrator.

Possible fix 3: http://blogs.technet.com/mu/archive/2008/10/02/windows-update-and-automatic-reboots.aspx

Can you access the group policy editor? Go to the "Policies to Change Automatic Rebooting Behavior" part of this article to find out how.

share|improve this answer
    
sorry, i am using Vista Home, which this article says it doesn't work for... –  Jason Jul 30 '09 at 21:57
    
"System error 5 has occurred. Access is denied." This is my personal machine... I should have access to everything... :\ –  Jason Jul 30 '09 at 22:02
    
ok this is sort of what i want... i don't necessarily want windows update to stop running, but i just don't want it to restart my comp when it does an update... –  Jason Jul 30 '09 at 22:11
    
posted some more info for you –  Troggy Jul 30 '09 at 22:20
    
vista home doesn't have the "group policy" editor... –  Jason Jul 30 '09 at 22:36
show 1 more comment

Run net stop wuauserv in cmd.

share|improve this answer
    
That completely disables automatic updates. Not a good idea. –  Tgr Dec 25 '12 at 11:34
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.