Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to trouble shoot an issue one of our users is experiencing with their laptop. Essentially they get a MULTIPLE_IRP_COMPLETE_REQUESTS STOP error when resuming the system from sleep mode. Now the obvious workaround is to disable sleep mode and then there will be no more BSOD. The user likes the sleep mode as they travel a lot away with the laptop and are unconvinced about having this disabled long term.

Things I have tried are deleting and reinstalling Kaspersky AV as the AVP.exe from the WinDBG output below made me think it was that to blame. ntkrpamp.exe also pointed me in this direction. Other people on the internet have suggested idle USB drives being to blame but the user is not using these when the crash occurs.

Another point of interest was the debug log suggesting it is usually video drivers. Brilliant, I thought, let's head over to Sony and download them. Unfortunately there are no updated video drivers. Perhaps NVidia has some then? It does but they are not supported for the Sony Vaio laptops. Start again :)

Does anyone have any potential insight in to this issue? Or possibly someone understands WinDBG output much better than I do?

Thanks

Tim

MULTIPLE_IRP_COMPLETE_REQUESTS (44)
A driver has requested that an IRP be completed (IoCompleteRequest()), but
the packet has already been completed.  This is a tough bug to find because
the easiest case, a driver actually attempted to complete its own packet
twice, is generally not what happened.  Rather, two separate drivers each
believe that they own the packet, and each attempts to complete it.  The
first actually works, and the second fails.  Tracking down which drivers
in the system actually did this is difficult, generally because the trails
of the first driver have been covered by the second.  However, the driver
stack for the current request can be found by examining the DeviceObject
fields in each of the stack locations.
Arguments:
Arg1: 85fbf7f8, Address of the IRP
Arg2: 00001d0b
Arg3: 00000000
Arg4: 00000000

Debugging Details:
------------------


IRP_ADDRESS:  85fbf7f8

FOLLOWUP_IP: 
nt!IopSynchronousServiceTail+221
82e467a9 8a4d13          mov     cl,byte ptr [ebp+13h]

CUSTOMER_CRASH_COUNT:  1

DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT

BUGCHECK_STR:  0x44

PROCESS_NAME:  avp.exe

CURRENT_IRQL:  1

LAST_CONTROL_TRANSFER:  from 82cb2631 to 82ccdb8d

STACK_TEXT:  
b3959c08 82cb2631 00000044 85fbf7f8 00001d0b nt!KeBugCheckEx+0x1e
b3959c30 82cb3407 85fbf7f8 2cb6068c 85fba0d0 nt!IopFreeIrp+0x22
b3959c78 82e467a9 85fbf838 b3959ca4 b3959ca8 nt!IopCompleteRequest+0x1bc
b3959cac 82e0b000 00000000 85fba0d0 00000001 nt!IopSynchronousServiceTail+0x221
b3959d38 82c4ac7a b5c51358 85fbf7f8 00000000 nt!NtReadFile+0x646
b3959d38 777d5e74 b5c51358 85fbf7f8 00000000 nt!KiFastCallEntry+0x12a
WARNING: Frame IP not in any known module. Following frames may be wrong.
0865f7ac 00000000 00000000 00000000 00000000 0x777d5e74


STACK_COMMAND:  kb

SYMBOL_STACK_INDEX:  3

SYMBOL_NAME:  nt!IopSynchronousServiceTail+221

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: nt

IMAGE_NAME:  ntkrpamp.exe

DEBUG_FLR_IMAGE_TIMESTAMP:  4b7d1e08

FAILURE_BUCKET_ID:  0x44_nt!IopSynchronousServiceTail+221

BUCKET_ID:  0x44_nt!IopSynchronousServiceTail+221

Followup: MachineOwner
---------

EDIT: In fact looking at the graphics card in more depth I am a touch confused. Sony say it is an NVidia 9300 GS while Device Manager states it is manufactured by NVidia but is Mobile Intel(R) 4 Series Express Chipset Family. Feel like I am losing my marbles. According to this site it may be that I have both graphics cards for power saving functionality. Could anyone that knows more than me about this possibly clarify it?

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted
+50

The notebook is question has hybrid graphics: It has both a 9300GS and an Intel Series 4. There is a little switch to change graphic cards on the top left corner of the laptop. See if the sleep problem occurs in both modes (Stamina or Speed). If it does, I would say your drivers are ok, the problem is somewhere else.

I recommend a BIOS update (if you haven't already done that), and a newer set of drivers (if you it doesn't show any new ones, just try searching for all notebooks from the same series in esupport from Sony, they all should work).

If you pinpoint the graphic card driver as the culprit of your problem, and even the Sony drivers don't work, try finding a "modded driver set" on the NotebookReview forums, or at laptopvideo2go.

HTH

share|improve this answer
    
oh now that is the kind of detail i was looking for! thanks very much for the pointers, I will look in to your suggestion and see what the outcome is. Thanks again –  Tim Alexander Jul 8 '10 at 15:38
    
seems to be holding up after the BIOS update despite the list of changes only being focussed on the Wireless card. Will assign the bounty once i get the all clear from the user. –  Tim Alexander Jul 9 '10 at 10:02
add comment

I recommend you to uninstall Kaspersky AV, and install/temporarily use Microsoft Security Essentials. Then test the machine for a while to see if the error occurs again. This way you can make sure if the problem is related to Kaspersky or not.

share|improve this answer
    
thanks for that. I have tried wtaniguchi suggestion and so far it seems to be holding. I have returned it to the user for further testing but if it comes back I may well try your suggestion. Thanks again. –  Tim Alexander Jul 9 '10 at 10:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.