Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Apple AirPort Extreme and it has been connected to DSL for internet connectivity. The AirPort base station is configured such that I can access the Internet from my laptops via the base station. The problem is I can't access my laptop A from laptop B, both of which are connected to the same base station. Is there a way I can do this?

I have done this in Nokia-Seimens Wi-Fi router where it was possible out of the box.

share|improve this question
    
I'm not sure how to even guess at answering this without more detail about your network configuration. What IPs and subnets are being used on the LAN side of your Airport Extreme? What devices, if any, are you able to ping by IP? Which flavor/model of Airport Extreme are you using? –  irrational John Jul 6 '10 at 17:12
    
You can assume any IP. IP doesnt matter to answer this question. I dont know what you mean by the second question. What do you mean by flavour? If its about base station/network card, it has been mentioned already that its base station. –  Mahesh M Jul 6 '10 at 17:29
    
According to the Wikipeida entry en.wikipedia.org/wiki/… there are apparently at least 7 different devices Apple has sold under the title "Airport Extreme". I was wondering which of these 7 you are using. –  irrational John Jul 6 '10 at 17:50

1 Answer 1

up vote 0 down vote accepted

AirPort Extreme base stations always forward frames between wireless clients. It is on by default and cannot be turned off. If laptop A can't see laptop B, your problem lies elsewhere.

Maybe multicast isn't working reliably, so ARP and/or your discovery protocol (Bonjour? NetBIOS Name Service?) isn't working reliably. Perhaps one of your laptops has a wireless card that doesn't handle multicast correctly (multicast handling can be tricky on 802.11 with certain wireless security combinations). Or perhaps you've set your multicast rate on the base station too high, and one or both of your laptops can't reliably receive multicasts at its current location.

As a temporary test, try disabling all wireless security on your base station, and setting its multicast rate to the lowest setting. See if that makes a difference. That should indicate whether or not you have a multicast problem.

If you still have the problem even with those settings changes, you probably don't have a multicast problem. You might have something set wrong on the personal firewall software on one or both laptops. You could try cabling up both laptops to the LAN ports of the base station and seeing if you can connect that way, to further isolate this problem from wireless.

share|improve this answer
    
What has mulitcast got to do with network discovery? Perhaps you're confusing it with something else? –  irrational John Jul 6 '10 at 17:09
    
I dont know if my previous configuration had something wrong. I configured it once again to same settings and it worked. You are right, frame forwarding is enabled by default. But cant figure out what was the problem earlier. Thank you. –  Mahesh M Jul 6 '10 at 17:31
    
Some models of the Airport Extreme support a "Guest Network" feature. When enabled this feature does exactly what you complained about. Clients can connect via wireless and access the Internet but cannot access the LAN. Perhaps you had mistakenly enabled this? (Seems unlikely, but it's the best I can come up with). –  irrational John Jul 6 '10 at 17:53
    
@irrational John, well-designed service discovery protocols use multicast. Poorly-designed ones use broadcast, which as far as 802.11 is concerned is a subset of multicast. Even if Mahesh wasn't using a discovery protocol at all, he'd be using ARP, which is broadcast, thus the same as multicast on 802.11. –  Spiff Jul 6 '10 at 22:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.