Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

For no reason I can determine, all of Office 2007 and Visual Studio 2008 have started running in what looks like 256 colour mode on my (up to date) Windows XP machine:

borked office

Other apps: Firefox, IE8, VS2005, Start Menu etc are fine.

I cannot seem to be able to get it working properly, I have tried/checked:

  • Shortcuts have default properties (No "run in 256 color" or compatibility options are set)
  • Problem still exists when apps launched in office safe mode
  • "High Contrast" in display settings is not set
  • Windows is using the correct video drivers
  • No errors in Office Diagnostics
  • No errors in event log
  • Flipping the Office theme/Windows theme makes no difference

I've seen a few reports of this via Google, but no definitive fix. (The SMS Mirror driver fix doesn't apply to me).

(I have 2 monitors running off an Nvidia Quadro NVS 440 using the latest drivers)

Any suggestions appreciated!

share|improve this question
3  
Have you run that PC through a terminal service lately? It is possible that somehow the remote session "hung" in that mode. Try logging on as a different user and see if the problem recurs. –  Mehper C. Palavuzlar Jul 6 '10 at 13:51
    
Agreed. I've had terminal services lock my local display into all kinds of weird settings. –  Satanicpuppy Jul 6 '10 at 20:07
    
Thanks for the suggestion, but the machine was never used with t/s. Some combination of uninstalling & manually sweeping out anything NVIDIA related then reinstalling the drivers seems to have fixed it. –  Alex K Jul 8 '10 at 9:58
2  
I have just upvoted your question as the image amuses me... :-D –  Tom Wijsman Jul 9 '10 at 16:36

4 Answers 4

up vote 1 down vote accepted

I had this problem. Went into the NVidia control panel and ran the Display Optimisation wizard. After that it was fine. Had to arrange my monitors again (so they were in the right order) and set my primary display, but it was fine after that.

share|improve this answer

According to google, this problem is caused by your dual displays.

Switch one off, re-boot and try to load office again.

share|improve this answer

I have managed to fix this issues by removing any display drivers especially dual display/wireless display, and reinstalling the video drivers.

share|improve this answer

I had this problem after installing Air Display and adding my iPad as an additional monitor. Even when I was not transmitting to the ipad-as-monitor via the Air Display app, Windows still had the ipad as an active monitor with my desktop extended to it. Once I unchecked Extend desktop to the ipad and clicked OK, office returned to the usual colors. I can switch it back forth with just the one setting, no restarts or driver re-installs. Also, the ipad was set in windows to 32-bit color, and it's obviously not a 256-color display, so not sure why this is happening.

PS: Windows indicated the ipad as "(default monitor)" so maybe it just thought the monitor was only 256-color-capable and downgraded the office apps to match?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.