Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Somehow or another, some, but not all, of flash objects now show up as empty rectangles on my browser.

For example, embedded YouTube videos simply don't display. Yet if I go to Youtube directly, the videos play fine.

I've tried uninstalling and reinstalling Flash several times, to no avail.

Any ideas?

share|improve this question
    
Have you installed any security software lately? Anything which may block flash applications in IE. Maybe antivirus, a adblocker, browser plugin? –  Daisetsu Jul 14 '10 at 0:32
    
Nope. Remember - flash works sometimes. It apparently works when the web page is using a <object> tag, but not when it's using an <embed> tag. –  Eric Brown Jul 14 '10 at 6:08
    
Right, but some browser security plugins will whitelist certain websites for Flash, so that Youtube still works when you're on youtube.com, but not when the video is embedded in another site. –  Phil P Jul 18 '10 at 1:41

5 Answers 5

I wonder if the problem is not with an overzealous antivirus product, that might be trying to protect you against active objects and cross-site scripting.

This theory can be easily tested by turning off all AV products, firewalls and other security measures for a short while.

share|improve this answer
    
Perhaps, but since the behavior is specific to IE (Mozilla, for example, works), it's unlikely to be a firewall/AV product. (I'll try this tonight anyway.) –  Eric Brown Jul 19 '10 at 20:21

You could try using a different web browser to see if it helps in any way. Also try clearing your Flash Cache.

Browsers:

http://www.mozilla.com/en-US/firefox/personal.html

http://www.google.com/chrome/index.html?hl=en&brand=CHMA&utm_campaign=en&utm_source=en-ha-na-us-bk&utm_medium=ha

Flash Cache Reset:

http://www.macromedia.com/support/documentation/en/flashplayer/help/settings_manager07.html

If you're using Internet Explorer 8, you made need to use this:

http://www.ieaddons.com/en/details/Time_Savers/Adobe_SVG_Viewer/

share|improve this answer
1  
Well, I tried Mozilla, and Flash works there; but I have a number of programs that use IE as an embedded renderer, so I'd like a solution that fixes the browser I actually use all the time. Tried clearing the Flash Cache, to no effect. –  Eric Brown Jul 7 '10 at 17:06
    
You probably already got this right, but make sure that you've got the version of Flash for IE. In other words, go to the Adobe site in IE to download Flash (Adobe makes a different version for Firefox, Chrome, and other browsers). If you downloaded and installed the Firefox version, it would naturally have no effect on IE. Good luck! –  jrc03c Jul 12 '10 at 20:23
    
Have you tried installing an older version of Flash? –  BioXhazard Jul 13 '10 at 14:40
    
Remember, flash works sometimes. For example, if I go to youtube or vimeo directly, it works fine; but if another web page embeds a youtube video, nothing shows up. I believe that it has something to do with <embed> versus <object>, but I'm not sure. –  Eric Brown Jul 15 '10 at 6:49

It may be an obvious suggestion, but have you deleted IE's temporary files?

I've known that fix some odd and otherwise baffling problems.

share|improve this answer
    
Tried it; no luck. –  Eric Brown Jul 14 '10 at 3:22
    
How about compatibility mode - Does that make a difference? –  Chris Jul 14 '10 at 18:10
    
Nope. Not a thing. –  Eric Brown Jul 15 '10 at 6:47

First - Uninstall Flash and reboot

Second - In IE got to Tools > Internet Option > Advanced > Reset. Then close IE.

Third - Open IE and download and reinstall Flash.

share|improve this answer
    
Why the downvote here? I really hate people that will cast a downvote without offering a technical explanation to the contrary. –  MDMarra Jul 13 '10 at 1:45
    
I think it's because he said in the origional description that he tried uninstalling and re-installing already. –  Daisetsu Jul 14 '10 at 0:31
    
Right, which is only part of what I suggested. Reseting IE resets the associated BHOs and plugins as well which is where the problem may lie –  MDMarra Jul 14 '10 at 5:53
    
Uninstalled, rebooted, resetted, reinstalled, and the behavior is exactly the same. Sigh. –  Eric Brown Jul 14 '10 at 6:04

Some attempts you could try:

  1. In Internet Explorer, go to Manage Add-Ons and check that Flash is enabled.

  2. Disable third party extensions and your virus scanners to ensure that they don't block Flash.

  3. Try to reinstall Internet Explorer again, if it came with Windows you can go to:
    Control Panel > Windows Components and disable the check-mark there, after a reboot, enable.

  4. Check C:\Windows\System32\Macromed\Flash or C:\Windows\SysWOW64\Macromed\Flash\

  5. Register all flash*.ocx files in above paths like this:
    regsvr32 C:\Location\To\FileName.Ext

  6. Go through http://kb2.adobe.com/cps/191/tn_19166.html
    This has been updated yesterday thus is very up-to-date, if those doesn't work contact Adobe.
    It's probably some kind of bug that we can't fix.

Good luck! :-)

share|improve this answer
    
I didn't read that Flash sometimes works, but going through all these steps should ensure a proper installation... –  Tom Wijsman Jul 16 '10 at 11:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.