Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

all. I have switched to openbox from Gnome and would now like to stop using Metacity altogether. When I was using metacity I had both a control theme (e.g. gtk theme) and fonts set up how I liked them in gnome-appearance-proporties. When Openbox starts, it gets my window borders up properly (ofc.) but fails to render my fonts properly and uses the wrong gtk theme. I can't find anywhere to specify which gtk theme to use or what method to render my text with. After Openbox is finished doing it's thing, and I run gnome-apperance-properties manually, it will automatically set everything to it's proper value, but I don't want to have to do this as it takes several seconds to preform and I'd rather not have it jury rigged like this.

Thank you!

share|improve this question
    
I think you want ~/.gtk2rc, or something similar. I forget what file specifically. –  Daenyth Jul 7 '10 at 3:37
add comment

2 Answers

Gtk theme, icon and font settings can be specified in the file:

$HOME/.gtkrc-2.0

If you don't want to manually edit this file, try lxappearance.

share|improve this answer
add comment
up vote 0 down vote accepted

/usr/libexec/gnome-settings-daemon manages all of this. I run it at startup now to avoid having to deal with the ~/.gtkrc-2.0 and font configs.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.