Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I already have 2 drives in my system, both are seagate 80GB IDE drives. The new one is a WD 320GB SATA. When I plug in the WD drive, I get to the Windows 7 "starting windows" screen then it goes to a black screen and does nothing.

Is the drive messed up?

share|improve this question

The first thing to check is the BIOS. You need to make sure it's configured to support both IDE and SATA drives. To find the appropriate settings you'll need to consult your motherboard documentation.

failing that, discovering the caus of the 'Black screen of death' is somewhat more tricky. Some believe it's caused by an MS update, whilst others believe it may be malware related. Essentially, the jury is still out.

One thing you might try is Prevx Black Screen Fix and you could take a look at this thread:

This problem is affecting a lot of people...

share|improve this answer
Well the drive went through a check for bad file segments, and the system booted up, i was able to copy files to the drive and all was good. Then I rebooted and now I get nothing. The mobo is set for IDE and SATA, first thing I checked after making sure it was being recognized. I will try the Black Screen fix and see if that works. 'edit' I just read up on the Black Screen fix and that's not the issue I'm having. After it shows the "Starting Windows" screen with the windows logo, that's when it goes black. Not after I log into my user account. – N. Lucas Jul 7 '10 at 8:27
Do you have access to ctrl-Alt-Del from the black screen or is everything dead? – Pulse Jul 7 '10 at 9:03
Everything is dead. I booted up with a Ubuntu live cd, it doesn't show the drive under my other file systems, but it's on there as /dev/sdc. When I run 'fdisk /dev/sdc' it shows there are no partitions, but when I run 'fdisk /dev/sdc1' and 'fdisk /dev/sc2' it's showing my two 150GB partitions on it. – N. Lucas Jul 8 '10 at 14:39
If this is not the way you have formatted the drive, it may be the partition table has become corrupt. There are ways to remedy this... – Pulse Jul 8 '10 at 16:25

I just ran WD's Data Lifeguard Diagnostics utility and I am getting an error on the drive at the cable test. I have tried three different cables and the same error. I guess I'm going to have to throw in the towel on this one and look at the drive as shot.

Thanks for the responses.

share|improve this answer

As suggested, with the drive connected, check your BIOSsettings for boot order and boot priority.

I assume it boots normally with the WD drive disconnected?

See if there is a jumper on the SATA drive and set it to SATA 1 operation. Jumpering pins 5 and 6 should put it in SATA 1 operation:

enter image description here

share|improve this answer
Well I found this last night and it told me to do pins 1,2 if the drive will be a slave, only problem is there is no jumper on the drive at all. Is there anything I can do and which pins should I jump if I need a jumper, 1,2 or 5,6? It's saying 5,6 is to enable 150MB/s data transfer. – N. Lucas Jul 8 '10 at 14:50
SATA doesn't use jumpers, it can be a 'master' on any channel. – Pulse Jul 8 '10 at 16:24
@Pulse, They have jumpers for other purposes. @N.Lucas, That old motherboard may not be compatible with the newer Sata hard drives, WD use to put jumpers on them so you could revert it back to SataI for compatibility purposes. What model number is the drive? – Moab Jul 8 '10 at 17:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .