Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an ASUS Eee netbook with Windows XP installed on it. Ever since I switched to an SSD drive, Windows XP has been doing something strange; Almost every time I reboot my computer, it changes my desktop theme. I'm using the Classic" Windows theme with a grey task bar:

enter image description here

However Windows keeps switching to the XP theme with a blue task bar:

enter image description here

I am able to switch back to my theme, but on the next restart I'll have to do it again.

I have reason to believe that the hard drive may have something to do with it, but I'll be happy to hear any suggestions.

Why is this? How can I stop this from happening?

share|improve this question
    
Waht did you use to copy the files from the HDD to the SSD? Sounds like it could be file permissions problems to me... –  Mokubai Jul 13 '10 at 12:30
    
cool-RR: Did you copied everything or did you do a fresh install? –  Tom Wijsman Jul 13 '10 at 12:53
    
Tomwij: I did I a fresh install on the ssd. –  Ram Rachum Jul 14 '10 at 8:55
    
Okay, that closes out any permissions problems as you did not copy any system files. Check my updated answer... –  Tom Wijsman Jul 14 '10 at 14:20
    
I encountered the same problem, finally, disabling the theme service solved this. but I still think its a hack. I'll try if using FAT32 will –  user169873 Nov 3 '12 at 12:44
add comment

6 Answers

up vote 4 down vote accepted
+100

Common reasons that cause this problem:

  • Settings that can have influence on the selected theme are configured wrong.
  • The Themes service is disabled or it's parameters/security/settings have been tampered with.
  • Windows is not saving it's settings when it shuts down.

How to fix this:

  • Right click this link, then save it on your computer and execute it after.
  • Do the same things with this link.
  • Reboot your computer, set the theme right and reboot again.
  • It should be fixed now.

The Registry files came from these sites:


Extra attempts:

  • Check at My Computer/Properties/Advanced/Performance/Settings that both
    "use visual styles on windows and buttons" and "use common tasks in folders" are checked.
  • http://www.softpedia.com/get/Desktop-Enhancements/Themes/RestoreXPthemes.shtml
  • Try to replace the theme that is wrong by the one that is right in C:\Windows\Resources\Themes\
  • If it still doesn't work, maybe creating a new user profile could fix this problem.
share|improve this answer
    
I did it now. It did a bunch of weird stuff. The theme gets changed to "classic" every boot, instead of just staying classic. And now the width of my (left-aligned) task-bar changes back to the default every reboot, probably because of the change to "classic". Another consequence of running your registry files is that I couldn't change theme anymore from the Display panel. (Became grayed out.) This is annoying. I used the registry editor to mostly revert these changes, but I'm still stuck with my problem –  Ram Rachum Jul 14 '10 at 9:21
    
This is weird as the things you explain don't match with the registry settings being changed... I've adjusted my answer, can you try these new things one by one? –  Tom Wijsman Jul 14 '10 at 11:33
    
I awarded the bounty to TomWij, since my answer was inspired by his. –  Ram Rachum Jul 16 '10 at 15:09
1  
I know this thread is very old, but I stumbled in here looking for a solution to this problem and this answer fixed it at ease. Had to create a SU account just to +1. Great job! –  Emerica. Mar 22 '12 at 13:27
add comment

Solved it myself. Hackishly, but solved it.

I went to the C:\WINDOWS\Resources\Themes folder, and renamed Luna.theme to Luna.theme_backup and the Luna folder to Luna_backup.

Now Windows can't find them and it stays on the classic theme.

share|improve this answer
    
Could you please denote my answer as the solution then, it includes multiple solutions towards this kind of problem and does include the answer you have just posted. You could then place the thing that helped as a comment (which I would upvote). The last line of the FAQ (meta.stackexchange.com/questions/7237/how-does-reputation-work) states that you do not get a single reputation point for accepting your own answer, if you would accept my answer you would get +2 points and help me with +15 points. This also has an effect on your accept rate I think... Thanks in advance. :-) –  Tom Wijsman Jul 16 '10 at 15:44
add comment

Are you using accounts or using the default account (just turn on computer and enter SO without passing Welcome Screen or login prompt)?

Try to create another account. It solved a lot of my problems with customizations some time ago.

share|improve this answer
1  
I don't think that a default account exists on Windows XP, and indeed, creating another account as I suggested two hours ago is a good fix if the problem is in the user registry or user settings and the problem is not system-wide. –  Tom Wijsman Jul 14 '10 at 14:23
    
@TomWij - if there's only one user on the machine, and it has no password, Windows XP will just auto-login in my experience –  warren Jul 14 '10 at 17:27
    
Yes. It will autologin, but using na administrator account with no password. –  kokbira Jul 14 '10 at 17:41
    
Well, there is more than registry changes when you change to another user ("Documents and settings" files will be different). Just try it - create another account and see if the problem occurs. –  kokbira Jul 14 '10 at 17:44
add comment

Right click My Computer -> Advanced -> Performance and set it to Adjust for Best Performance. This reverts to the classic theme if thats what you want, but its a hack I know.

share|improve this answer
    
It was already at that setting. –  Ram Rachum Jul 14 '10 at 21:20
add comment

You may check "Group Policy Editor" if the default system settings were changed (only available for Windows XP Pro).

Select "Run" from the Start menu, type gpedit.msc and hit Enter. Under Local Computer Policy, navigate to User Configuration > Administrative Templates > Control Panel > Display > Desktop Theme. Now on the right pane, you'll see some settings and their states. Change them and save & exit GPE. Change your theme the way you want, reboot and tell us if this works.

share|improve this answer
    
Tried enabling "Load a specific visual style ...", didn't work. I rebooted and it changed to the XP theme again. –  Ram Rachum Jul 14 '10 at 8:54
add comment

It could be that the program that you used to copy the Windows files from the previous media to the SSD did not properly copy over all the file permissions for your user in Windows XP and so your settings are not getting written back to disk as you are no longer the "owner" of the files needed to save your desktop settings.

I would Open a new Explorer window, navigate to "C:\Documents and Settings\" select the user directory that corresponds to your account and use these steps (taken from here):

Right-click the folder that you want to take ownership of, and then click Properties.

Click the Security tab, and then click OK on the Security message (if one appears).

Click Advanced, and then click the Owner tab.

In the Name list, click your user name and select the Replace owner on subcontainers and objects check box.

Click OK, and then click Yes when you receive the following message:

You do not have permission to read the contents of directory folder name. Do you want to replace the directory permissions with permissions granting you Full Control?" All permissions will be replaced if you click Yes.

share|improve this answer
    
Tried it now, didn't work. –  Ram Rachum Jul 14 '10 at 9:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.