Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Microsoft mouse keeps turning on and off, and now i got error code 43 and it just turned off completely.

I have a regular Microsoft 3-Button usb wired optical mouse. Recently it has started turning on and off, and now it gets error code 43 in the device manager. If I disconnect and reconnect it, it seems to work for a while then starts to turn on and off again and eventually gets error code 43 and turns off completely.

I have tried to connect the mouse to other usb ports, and it happens in them all. Tried reinstalling and updating the usb and the mouse drivers.

The strange thing is, when I connect that same mouse to a laptop, it looks like it works fine, no errors or nothing.

UPDATE: ended up buying a new (exact same) mouse, and it worked. Must have had something in the old one.

share|improve this question
    
Code 43 is a hard one - Do you have problems with any other USB device? –  William Hilsum Jul 7 '10 at 13:24
    
Right now it seems all other USB devices have no problems at all. –  kkaploon Jul 7 '10 at 13:31
add comment

2 Answers

According to Microsoft, the error code 43 in the device manager stands for an error, which was reported by the device. Microsoft advices to take a look into the hardware documentation.

Those device errors are reported by the corresponding drivers. Do you use the same drivers on both computers? Maybe its really just a driver issue. How did you un- and reinstall them?

share|improve this answer
    
On both computers I just use the default Microsoft drivers. And when I uninstalled it, I just let it reinstall the default drivers back. –  kkaploon Jul 7 '10 at 13:30
    
Do you use the same version of Windows on both machines? Maybe one of them has different drivers. It's unlikely that Microsoft will offer an additional driver for this mouse, that cannot be found in Windows / via Windows Update, but you might want to take a look if such a driver exists. If so, try this driver instead of the standard one. Otherwise I have no idea, how you could solve this issue. –  Elvith Jul 7 '10 at 14:52
    
Both machines have win 7 on them and both had the windows update drivers installed on them. –  kkaploon Jul 9 '10 at 7:58
add comment

I had a similar issue a couple of years back, and the way I solved it was a BIOS firmware upgrade. EXTREMELY dangerous to perform for the inexperienced, but if you trust yourself it may be worth looking in to.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.