Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm having a strange problem with Team Foundation Server and Windows Integrated Authentication.

I have two different computers I'm currently using to connect to a single Team Foundation server. Both computers and the server are on the same Active Directory, which should allow Windows Integrated Authentication to automatically authentify myself when accessing the TFS server.

This configuration works fine on one of the two computers. I can add the server in Visual Studio and connect to it without having to authentify myself. However, on the second computer, I am unable to use WIA. When I add the TFS server, it asks for my credentials, and then rejects me with an error saying I do not have sufficients rights to connect to the server.

I am interested in any idea which could help me solve this problem :-)

share|improve this question
    
Try log off from the first computer. Log on to Windows on second one and try add TFS server. – Julius A Jul 7 '10 at 13:28
    
@J Andwenyi : I was not logged on the second computer when I tried on the first, will try eventually, but I don't think this is the problem. thanks anyway ;-) – user37510 Jul 7 '10 at 16:37
up vote 1 down vote accepted

I solved the problem by removing Team Foundation Server cache directory on the machine which had problems.

Apparently, the old references to a previous Team Foudation Server were causing some conflicts when trying to connect to the new server.

The cache directory is located in the Local Settings\Application Data\Microsoft\Team Foundation directory. Delete the 1.0 folder for VS2005, or 2.0 folder for VS2008.

share|improve this answer

This may be a problem with your LMCompatibility setting in the registry. Take a look at this key on both machines:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Lsa

Add or modify the key labelled LMCompatibility (it's a dword) and set it to whatever the working computer has on it, or try it with either 3 or 2. Remember to reboot whenever you change it.

share|improve this answer
    
I have no key labelled LMCompatibility on both machines. I found a LMCompatibilityLevel, but both machines have the same value (1). – user37510 Aug 12 '10 at 8:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .