Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have searched around online for an answer to this one without any luck.

Every couple of days, on my PC I get an error with Skype, that says Disk Full. I have plenty of HD space so I know that is not the issue.

I am able to resolve the problem temporarily by killing the skype process and restarting skype.

Does anyone know of a solution to this problem to stop it from happening?

I am running Skype 4.2.0.169.

share|improve this question
1  
What partitions do you have? Where is Skype installed? Where is the temporary folder? –  Gnoupi Jul 7 '10 at 15:43
    
Skype is installed on my C: in the default install location. Im guessing that the temp folder would also be set in the default location. Where can I actually confirm this? I have a separate hard drive strictly for data also with no applications installed on it. –  commradepolski Jul 7 '10 at 17:58
    
I was just checking, in case you would have Skype on one partition with a lot of space, and the C: partition, with the temp folder, full. Apparently, it's not the cause. –  Gnoupi Jul 7 '10 at 18:07
2  
A lot of people are having this issue as Ive seen on Google so it looks like it a problem with the Skype software its self. Thats unfortunate because Im sure a lot of businesses, such as the company I work at, that are world wide, use skype to save on costs of long distance phone calls. Hopefully a solution shows up soon. –  commradepolski Jul 7 '10 at 18:10
add comment

8 Answers

This is a repost of a post from a solution on the Skype forums.

This works (I tried it myself...)

  1. Quit Skype.
  2. Rename the Skype folder in Application Data (replace <username> with your actual username):
    • For Windows 7 and Vista: C:\Users\<username>\AppData\Roaming\Skype
    • For Windows XP, C:\Document and Settings\<username>\Application Data\Skype
  3. Try to log into Skype again.
share|improve this answer
add comment

Havent had this problem crop up since I upgraded to Skype 5.0. This looks to be the best solution.

share|improve this answer
add comment

Have you tried to reinstall Skype? or even downgrade to an older version? (or the opposite - newer version) That might do the job and solve your problem.

share|improve this answer
    
I have tried reinstalling and that helps for about a week before the issue returns. The install I am running was the latest last month. I will check the site again and see if theres a newer version. I will also try a downgrade if there is no newer version. –  commradepolski Jul 7 '10 at 17:52
add comment

Is it possible that your computer has become a Skype Supernode and it is related to all the connections?

Skype is a shared app like a P2P file share app. If it is running all the time and you have a reasoanble Internet connection and a faster system, Skype will start to route user calls through your connection. You become a Skype supernode. I found this on my home system where it was always running

This is some info we found related to some research by a University Can't find original info at the moment

Skype uses a node-base Peer-to-Peer Model, where individual clients perform some processing tasks on behalf of the network . This model allows for "Supernodes " to be created. Supernodes are where individual computers begin to route a sizeable amount of 3rd party traffic, 200MB per hour has been detected on the some networks from the Skype network. One study has measured a supernode over a 24 hour period to log 319,314 flows to and from 38,366 IP addresses.

The way Skype functions is that each node can handle the calls of any other user. Some systems will become a super node and handle tens of thousands of calls, all for otehr users. This happens when a Skype client runs all the time and has a good connection. Not sure how the determination is made, but it happens. You then have lots of network traffic and hard drive action for these calls. Try exiting(Quit) Skype when not in use. Not just minimizing. I had this issue on a desktop that ran all the time and Quiting Skype solved the issue.

share|improve this answer
    
Not sure what you mean by this. Can you describe it a bit better? Are you saying that Ive had a lot of skype calls on the machine and that the connection is somehow left open? –  commradepolski Jul 7 '10 at 17:51
    
Please see added comments –  Dave M Aug 17 '10 at 22:55
    
Thanks for the info. The problem here is that people are always leaving Skype open and I cant really start telling them to exit it as they do get messaged and called while away from the desk. It makes sense that computers here are becoming supernodes since we are on an 80mbit connection. Is there a reg hack or anything that can be done to prevent this from happening? –  commradepolski Aug 27 '10 at 14:50
    
Skype for Business has a manager app that may give you more control. Have not looked at it yet for our users. skype.com/intl/en-us/business/skype-manager –  Dave M Aug 27 '10 at 17:37
add comment

I have seen error messages like this one caused by program unable to allocate handles. It could be caused reaching the limit of open files or open sockets (supernode ?).

This usually indicates programming error and some form of leak. The only fix would be upgrade to a version with the problem fixed - or avoid condition that triggers it (e.g. becoming supernode).

share|improve this answer
add comment

BTW do not try the renaming thing, doesn't work. I think what you may need to do if you have searched all the possibilities is write down all the names of your contacts or save them somewhere and then reinstall Skype. Or uninstalling and installing. Very inconvinient.

share|improve this answer
add comment

For Windows 7 and Vista:

  • C:\Users\<username>\AppData\Roaming\Skype

For Windows XP:

  • C:\Document and Settings\<username>\Application Data\Skype

Go there and delete the folder with your user name. That's all.

share|improve this answer
add comment

You never posted how much disk space is "plenty of hd space". It's quite possible the version of Skype you're using is checking available disk space using a 32bit integer which is overflowing or becoming negative (if signed) which triggers skype's 'disk full' message.

Killing and restarting the skype process likely works immediately again since a file was written or removed or changed and now the 'free space' calculation works this time.

Personally, software should NOT be checking how much space I have, none of their business, my OS keeps track of that. Quite a few older programs have failed in recent years as hard drive storage sizes exploded and overflowed signed 32bit integer based space checkers.

share|improve this answer
add comment

protected by slhck Jun 21 '12 at 19:22

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.