Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Here's what I did:
At first I had nvidia drivers from 195 series installed from Ubuntu repositories and everything worked fine. I used system for some time, settled into it and have some data I don't want to lose.

When stable 256 drivers came out, I uninstalled old drivers and installed drivers I downloaded from nvidia. I did this many times on SuSE, so I know how the procedure goes. At first everything was fine. At this moment I should mention that usual uptime for my computer is about 5-6 days. Also I had RGBA Gtk+ module installed for a short while, but I uninstalled it. After couple of weeks, I noticed that I have to rebuild kernel module for nvidia driver after every reboot, because for some reason kernel would load 195 module.

Few days ago, the workaround stopped helping. I uninstalled new drivers, installed 195 and made new xorg.conf. Still, I'd get low-graphics mode and options how to fix it. I tried with various settings in xorg.conf, but nothing could help. I decided to give up and move data to windows partition.

Then I noticed that when I set driver to vesa in xorg.conf, I'd get gdm's log-in screen an after that white rectangle in the center of the screen. After a minute it disappears and I get log-in prompt again. I tried whit various setting, but nothing helped me. I decided to get rid of gdm, so I purged it and switched to KDE. I installed KDE and now after kdm prompt I just get terminal. I can run programs from terminal normally, but the programs don't have the underscore, squares and X to close them. Also, I can only have one program displayed at one time and I can't drag windows.

Any tips on how to solve this issue without formatting Ubuntu partition and doing all from start? Also, I tried purging xorg, drivers and related stuff and installing it all again. It didn't help.

share|improve this question

2 Answers 2

boot as root,then run:

startx

to enter window

share|improve this answer
    
I get a black screen and have to bring X server down in such situations. Anyway, I can get to terminal from KDE, but I'd rather not reinstall Ubuntu, if possible. –  AndrejaKo Jul 8 '10 at 11:06
    
does you have a choice to select root revocery when boot? i use mint ,have two boot menu item. –  chenge Jul 8 '10 at 12:08
    
There is a second choice, but it doesn't have any more options than first. Just to be clear, I can access root account and use terminal, I just have no idea how to fix the mess. –  AndrejaKo Jul 8 '10 at 12:15
    
maybe you can goto ubuntu wiki to get some thread. –  chenge Jul 8 '10 at 12:50
up vote 0 down vote accepted

Well, I have no idea what happened in the meantime, but here's what looks like the fix for the problem:
I did

sudo apt-get update && apt-get upgrade

After that, I did what was said here. After installing drivers and running

 sudo nvidia-xconfig

I managed to boot into graphics mode. So far everything looks fine.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.