Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Lenovo T60 with Ubuntu 10.04 connected with a cross-over cable to a Dell Vostro 1400, also running Ubuntu 10.04. My internet is coming into the Lenovo through an external wireless antennae, and I want to share the internet with the Dell.

On the Lenovo: eth0 connection has IPv4 Settings 'Shared to other computers' I can ping the Dell (10.42.43.10) successfully I can use mtr to trace to www.google.com successfully

On the Dell: eth0 connection has IPv4 Settings 'Automatic DHCP' I can ping the Lenovo (10.42.43.1) successfully when I use mtr to trace to www.google.com, I can only reach 10.42.43.1

I must be missing some setting, but cannot see what it is; can anyone help me?

share|improve this question
    
just to note, most modern systems, should probably autonegotiate networking, so so using a crossover cable isn't necessary. –  Journeyman Geek Aug 26 '11 at 0:49
add comment

2 Answers 2

Well another very simple setting could be using a static IP address scheme on both machines, so for instance

Dell 10.42.43.10
Lenovo 10.42.43.11

with the same subnet mask lets say 255.255.255.0 or /24.

Once this is done you can easily through the network manager share the Wifi connection through the cable.

share|improve this answer
add comment

There is an extensive description how to do this in the Ubuntu help:

https://help.ubuntu.com/community/Internet/ConnectionSharing

In particular, the package dnsmasq-base must be installed.

Try installing the package, then reboot, and do the setup again, then try again with a client computer.

If it still fails, have a look at the system logs (/var/log/syslog), there might be a helpful message there.

To troubleshoot, get a root shell on the client computer (sudo su), then type:

dhclient -d

This will try to obtain network parameters automatically (via DHCP). If it fails, something is wrong on the ICS server. If it works, you're good.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.