Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Most of my work happens in a terminal, so I need a clear, readable font. I've settled a while ago on Terminus (, which works wonders for me.

I added XTerm*faceName : Terminus in my ~/.Xdefaults, and I do get the Terminus font. Unfortunately, a lot of Unicode glyphs are missing (mathematical symbols, greek and hebrew letters), displaying as little square blocks instead.

If I remove the faceName entry, the default configuration seems able to display most of the glyphs (including math, greek, hebrew, runic, and whatever else), but the default font is much harder to read.

A google search hints that it should be possible to use Terminus as the default font, and fallback to (an)other one(s) for missing glyphs, but provides no further explanation. I've seen documentation that recommends Bitstream Vera Sans as a fallback, but it lacks the glyphs I need too; I don't know how to identify the default font used by xterm either, I had a look at /usr/share/X11/app-defaults/XTerm, but all I can find are generic references to old pre-fontconfig font names.

Using Gentoo Linux, fontconfig and xterm are up to date, USEs trutype and unicode enabled, X.Org server 1.6.

Edit: I alternate between Ratpoison, Awesome and XMonad, without a desktop environment.

share|improve this question
up vote -1 down vote accepted

xterm is not a friend to fontconfig. Consider using something like Terminal instead.

share|improve this answer
I'll give it a try. I forgot to mention i'm using ratpoison without any desktop environment. – b0fh Jul 8 '10 at 18:20
Terminal doesn't need XFCE in order to run. It just happens to be the default choice for it. – Ignacio Vazquez-Abrams Jul 8 '10 at 18:27
Indeed, but I was slightly bothered by the dependance on gnome libs. You were right however, it does work properly now, and by removing the tool- and scrollbars, I get almost as much screen estate as with xterm. So, in lack of a better solution, answer accepted ! – b0fh Jul 8 '10 at 18:53

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.