Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After moving a website folder on my local development machine to another drive, then moving it back, I got a 403 error. Most of this problem had probably to do with rights that got messed up. After deleting the code and restoring it from SVN, the rights seemed allright. The error stayed however.

The setup is a bit complex, as follows:

  1. I have Ubuntu 10.4 as development machine, trying to mimic the server as much as possible
  2. We use Eclipse + SVN and I create all projects in a local folder under my user account
  3. In /var/www-vhosts I create folders for each vhost, like this one: test.localhost
  4. test.local/index.php: includes the index file of the project
  5. test.local/.htaccess is a dynamic link to the htaccess file in a project subfolder

I get the following error in the apache error log:

[Thu Jul 08 15:55:56 2010] [crit] [client 127.0.0.1] (13)Permission denied: /var/www-vhosts/test.localhost/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable

The problem seems to be the .htaccess file, or the link to it.

  1. When I empty the htaccess, nothing changes
  2. When I remove the link, the index-include produces some output (in the apache error log)
  3. When I remove the link and replace it with the actual file, I get another error:

[Thu Jul 08 16:47:54 2010] [error] [client 127.0.0.1] Symbolic link not allowed or link target not accessible: /var/www-vhosts/test.localhost/test

I'm lost here, don't know what to do next. Do you have any ideas what I can try? This setup has worked before, but I don't know what is different now.

share|improve this question

1 Answer 1

up vote 8 down vote accepted

It turned out that the parent folders of the project folder had only user-rights, no rights for other groups. After setting these rights back to normal, it works again.

share|improve this answer
    
Same here, thanks for the answer! –  Kzqai Nov 8 '12 at 16:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.