Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Preparing to replace mysql-server-5.1 5.1.41-3ubuntu12.1 (using .../mysql-server-5.1_5.1.41-3ubuntu12.3_amd64.deb) ...

It hangs until i reboot the thing.

This is not a normal error.
I'm trying to fix it for at least 10 days.No Success.
It happens when i try any package operation.
Please help me.

share|improve this question
    
Come to #Ubuntu on Freenode IRC. I'm shiki- there if no one else helps. :) –  Shiki Jul 8 '10 at 19:22
    
Eek.. that's already wrong. Best place for this is IRC. Try using the webIRC, or connect through SSL, or try TOR... or..well..best would be a VPN. Here is a free VPN. (But honestly, I'd ALWAYS use a VPN in such a country): itshidden.com –  Shiki Jul 9 '10 at 5:42
    
@Shiki:if you find a VPN in IRAN, there may be two cases:1.you work for GOV, 2.you are a genius.genius people don't ask such questions here. –  behrooz Jul 9 '10 at 12:20
    
As I said you can connect to a VPN outside. Like the ones I linked. –  Shiki Jul 9 '10 at 16:37
    
well, if IRC could fix.. everything.. this place wouldn't need to exist. in addition, if someone else had the same issue, they could look it up here. You can't do that on irc. –  Journeyman Geek Jun 27 '11 at 6:06
add comment

2 Answers

Sorry if these are obvious, but maybe they'll help you look at a variety of things:

Do you have a good internet connection? Package lists are downloaded and compared first before upgrades happen. Bad connection may cause hang.

Do you have a CD or DVD that you could reinstall just the package manager from?

Is this the ONLY problem you're having with the system?

Did you check the appropriate boxes where it asks for what sources to draw packages from? I assume yes if you've got the previous version but like I said, better to ask than to overlook.

Try the other update method - if graphical then try apt-get, or vice versa.

Hotei

share|improve this answer
    
I have used graphical interfaces and apt-get.My connection speed is 2Mb/s. and this is the Only Problem. –  behrooz Jul 8 '10 at 19:31
    
Have you run the "update manager" lately? I'm assuming you've run Synaptic and apt-get, but have you got an "up-to-date" baseline? I run 10.4 LTS AMD64 and have had no problems with updates. I just this moment installed mysql server with no problem so I can only think that something on your system is "broken/misconfigured". I know that's not a whole lot of help. Have you got any other packages which might have caused conflicts? –  hotei Jul 8 '10 at 22:31
    
I said its not a normal problem.and its reason is a system reboot due to power failure.also I'm running the very same version. –  behrooz Jul 9 '10 at 3:30
    
@behrooz: The power failure is significant info. Have you tried to boot the installation CD and use the "Fix Broken System" option? Does your boot up log give any clues that something failed to load (say in the dmesg output)? Failing that I guess you're in for a backup data and reinstall OS. No big deal if you've kept track of the changes you've made after baseline OS install. Going forward I'd suggest a UPS as insurance against short power outages. A UPS won't prevent all power issues but I've used APC for a long time and am happy with results. –  hotei Jul 9 '10 at 19:14
add comment

i'm wondering if its waiting for something to happen... try switching virtual terminals (ctrl alt fx - for some value of x) to make sure its actually frozen. in this order

You should also try dpkg --configure -a to ensure things are consistent. then try checking if apt works normally.

If that makes no different try downloading the .deb from ubuntu directly and seeing if it will install with dpkg -i

you could also try seeing if uninstalling it with apt-get remove, and reinstalling it, but i'm not entirely certain if this will delete current databases as well.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.