Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I work for a software development company but the issue doesn't seem to be programming-related.

Here is my setup:

  • Windows XP Professional with Service Pack 3, all updated
  • Program that sends UDP datagrams
  • Program that receives UDP datagrams
  • Windows Firewall set to allow inbound UDP datagrams on a specific port (Scope: Subnet)

If I send a UDP datagram on any port to other, similar machines, it goes through. If I send the UDP datagram to the same computer running the program that sends (whether using broadcast, localhost IP or the specific IP of the machine), the receiver program gets nothing.

I've traced the problem down to the Windows XP Firewall, as Windows 7 does not have this problem (and I do not wish to sully my hands with Vista). If the exception I create for that UDP port in the WinXP firewall is set for a Scope of Subnet the datagram is blocked, but if I set it to All Computers or specifically enter my network settings (192.168.2.161 or 192.168.2.0/255.255.255.0) it works fine. Using different UDP ports makes no difference.

I've tried different programs to reproduce this problem (ServerTalk to send and either IP Port Spy or PortPeeker to receive) to make sure it's not our code that's the issue, and those programs' datagrams were blocked as well. Also, that computer only has one network interface, so there are no additional network weirdness. I receive my IP from a DHCP server, so this is a straightforward setup.

Given that it doesn't happen in Windows 7 I must assume it's a defect in the Windows XP Firewall, but I'd think someone else would have encountered this problem before. Has anyone encountered anything like this? Any ideas?

share|improve this question
add comment

1 Answer

The firewall settings might be screwed up in a weird and wonderful way.

You might try to rebuild all firewall settings from scratch, by clicking the "Restore default settings" button of the advanced tab in Windows Firewall, then redo the exception.

One note: I wonder if this happens on other XP machines in your domain. Remember that in a domain, Group Policy settings may override local firewall settings.

share|improve this answer
    
Good ideas, Harry. We have a domain but that machine isn't on it. I can reproduce the problem on multiple machines--sorry, forgot to mention that--and we're getting reports of this issue at workgroup sites; no domain. I reset the firewall and recreated the UDP exception. It worked, but that's because the firewall then prompted to allow the server app through the firewall and gave it the All Computers exception. Once I set that exception to Subnet the problem came back. So it seems that either the port or program exception requires All Computers for this to work, which is the same issue. –  user36367 Jul 8 '10 at 20:40
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.