Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How to insert Hindi or Swedish characters in VIM

When I insert these words it appears as "......"

share|improve this question

migrated from stackoverflow.com Jul 9 '10 at 0:15

This question came from our site for professional and enthusiast programmers.

    
Not enough information. VIM can be run in a many ways: as GVIM locally or on foreign X Window server; as VIM locally in terminal or in terminal emulator or over ssh from other box. Problem could be in both input and output and without knowing what are they it is impossible to respond to the question. –  Dummy00001 Jul 8 '10 at 10:46
add comment

2 Answers

up vote 1 down vote accepted
  • Try :dig for a list of special chars which you can insert with CTRL + K and :help dig for explanation.
  • Check if your font is able to display the special chars
share|improve this answer
add comment

Vim has no problem with Unicode characters outside of ASCII. The problem is most likely to be found in either the font you use in Vim, or in the setup of your system. To find out what isn't working, we need more information, such as

  • What font are you using in Vim?
  • what's the output of running locale in a terminal?
  • What's the result when you try to write one of these swedish/hindi characters in a terminal, and in gedit?
share|improve this answer
    
Locale gives the following output [root@localhost site]# locale LANG=en_US.UTF-8 LC_CTYPE="en_US.UTF-8" LC_NUMERIC="en_US.UTF-8" LC_TIME="en_US.UTF-8" LC_COLLATE="en_US.UTF-8" LC_MONETARY="en_US.UTF-8" LC_MESSAGES="en_US.UTF-8" LC_PAPER="en_US.UTF-8" LC_NAME="en_US.UTF-8" LC_ADDRESS="en_US.UTF-8" LC_TELEPHONE="en_US.UTF-8" LC_MEASUREMENT="en_US.UTF-8" LC_IDENTIFICATION="en_US.UTF-8" LC_ALL= –  Hulk Jul 8 '10 at 7:32
    
that answers one of the three questions I asked.... –  gnud Jul 8 '10 at 12:45
    
Since the locale settings look fine, my guess is that the font does not support these characters. Choose another font. –  Scytale Aug 11 '10 at 22:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.