Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

For about a week now I can not access any sites with https:// in them, I have googled and tried every trick I can find with no luck.

Example site is I can view it but I can not log in as it uses secure server

Can anybody help me?

Also I am using google chrome and firefox and IE and none of them will access these sites so I don't think it is browser specific in this case

Most things on google claim it is fromthe browser, not in my case.

Also note I am not sure if you can generally ping this site but when I do it, it times out

Moderator Edit (quoting from a comment to an answer):

I just restarted my router and now i can access these sites!

share|improve this question

migrated from Jul 31 '09 at 5:38

This question came from our site for system and network administrators.

As https by default uses port 443 rather than 80 have you checked any firewall settings? – mas Jul 31 '09 at 5:20
Are you using a Proxy Server? – Michael Stum Jul 31 '09 at 5:23
disabled firewall and no proxy server I have tried a lot of things – JasonDavis Jul 31 '09 at 5:35
I can successfully ping Check to see your router isn't blocking any traffic. – Jared Harley Jul 31 '09 at 5:52
I am looking at my router settings, I use so I tried it without there ip's and still does not work, however I was able to successfully access 1 https stie here but nothing important will work, I cant login to paypal, ebay, hulu and I do not know what to do I have tried everything you can find on google and here so far – JasonDavis Jul 31 '09 at 5:54
up vote 3 down vote accepted

Do this simple test to check if the outbound path from your machine to https (tcp/443) is blocked.

  1. Open a cmd.exe shell to execute the following
  2. execute ping
    • this will give you the IP address resolved, we will use that IP for the remaining steps
  3. execute telnet GOOGLE_IP 80
    • This will give you a 3 line output that ends with Escape character is...
    • use the Escape sequence to get the telnet> prompt and quit from it
    • ^] is Control + the ']' buttons
    • getting the Escape sequence line implies you were able to connect google on the HTTP port
  4. execute telnet GOOGLE_IP 443
    • If you get the same 3 line output and can do the same things to get out,
      • your outbound path (at least towards Google) is fine for HTTPS
      • you need to focus on the application (browser) you are using for your problem
    • If this stopped on the first line saying Trying ...,
      • you could not reach the HTTPS at Google, something is stopping you on the network path
      • this could be something on your machine (local firewall) or a network device in the path
      • To identify where the path is breaking, you will need to get a little more involved...

Identifying if the HTTPS connect attempt is forming on your machine. (or something on the machine is blocking it; which could eventually lead to the application you are using itself)

You can have a second cmd.exe shell around where you fire the following command just after your telnet attempts.

netstat -an -p tcp

For the Foreign Address matching the GOOGLE_IP in the above example,

  • This will show an ESTABLISHED following the :80 or :443 when you get a successful connect.
  • And, it will show a SYN_SENT following the ports when you have sent the connect attempt but there is no response (because some firewall blocked it?)
  • You can compare the behavior between ports 80 and 443 for HTTP and HTTPS

One way to get a Telnet client on your Windows 7

share|improve this answer
I am on windows 7 and in cmd I cannot seem to get telnet – JasonDavis Jul 31 '09 at 6:17
I was able to get a telnet program on windows 7 but i couldnt run anything like above I tried this o 80 but it would show 3 dots flashing forever – JasonDavis Jul 31 '09 at 6:28
You need a console application (like the default telnet) to easily understand what is happening. Did you check netstat while the dots were flashing? Did you try to install the default telnet from the steps on that link i added? – nik Jul 31 '09 at 6:33
I just restarted my router and now i can access these sites! – JasonDavis Jul 31 '09 at 6:34
good for you :-) – nik Jul 31 '09 at 6:39

Sounds like your firewall is blocking outbound HTTPS.

share|improve this answer
i am on windows 7 i disable the windows firewall but that didnt help, could there be something on the router i need to do? – JasonDavis Jul 31 '09 at 5:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .