Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The problem can be found in the title. I've been using Office since a very long time. Office 2000, 2003, and now 2007. My office is the Hungarian edition, the SP2 patch have been applied through the Windows Update. So far, I've never seen this problem.

Basically when I try ctrl+a in a file, ctrl+c, and open a new file (ctrl+n), it pop ups this message.

As I said it's been working for a veeeery long time like this. The computer got 3gb free memory, enough CPU, enough everything. Tried applying the SP2 fix again, it didn't work. Found a hotfix for this, kb956506 but it didn't apply. It said "the expected software cannot be found on your PC".

Now.. I'm stuck. Any idea / suggestion are welcome..

NEW Information: It is an Office 2007 Basic OEM. I thought its an in-built limit but it was working for so long .... that just can't be the case. First it works and after someone it doesn't.

Oh yeah I forgot:
- Tried to remove AppData stuff, nothing happened.
- Tried to search for duplicates, but couldn't find anything.
- Total clean install, removing regkeys, settings, blah blah, didn't help.
- I don't have a .xlb file on my PC so deleting it quite impossible.

Here is a video about the problem (Sorry, it is a Hungarian Excel.)

It turns out, Ditto is the problem here. Reported the bug, hope the Ditto devs will fix it since I really love Ditto and it's a must. Once you get used to it, you don't want to abandon it. (Like "Everything";"F.lux" and so on).

share|improve this question
Tried resetting settings. After it finished, the Office set up screen popped up. Typed my key once again, everything is fine, Office up and running. BUT it is still FUBAR. It does not work. Any idea...? – Shiki Jul 9 '10 at 18:52
up vote 3 down vote accepted

Apparently there is more than one reason for this problem.
Here are some references:

excel cannot complete this task with available resources
Two possible actions:

  • Delete all files in C:\Documents and Settings\*USERNAME*\Application Data\Microsoft\Excel and reboot
  • Search and delete file Excel11.xlb

Excel 2007: Excel cannot complete this task with available resources
Save as an .xslx file to solve the problem

Error message when you open a workbook that contains cells that you filled with a reference to a relative name in Excel 2007: "Excel cannot complete this task with available resources"
Although this doesn't sound suitable according to your description of the problem.


See this article:
What to do if you get an out of memory or not enough resources message
which contains a lot of advice concerning this problem, too many to list here.

From my side, I would like to ask two questions:

  1. What is the memory usage of Excel as seen in Task Manager?
  2. What happens if you launch Excel from another user account (create one if required)?


Since it works under another user account, I would suggest to:

  1. Uninstall Office
  2. Verify that everything was really cleaned out as described here:
    How to manually uninstall the 2007 Office system
  3. Run very carefully a few register cleaners, such as CCleaner, Eusing Free Registry Cleaner or TweakNow RegCleaner.
  4. Reinstall Office.

If this doesn't work, then your user account is really unusable.
Then the best I can think of is to rename it, create a new account that has the same name, and use that instead.

share|improve this answer
Tried the Application Data way, and I could only find "Excel12.xlb". Well.. lucky that tomorrow is Saturday so I'll be able to try out all you wrote down (everyone) and hopefully I'll find a solution..just waiting for the install disc. – Shiki Jul 9 '10 at 19:23
@Shiki: Good luck, but I can't guaranty success. Your problem might not be in this list. There is of course also the solution of uninstalling Excel, cleaning out all directories, and reinstalling. – harrymc Jul 9 '10 at 19:58
@Shiki: Excel12.xlb is probably ok to delete instead. But take backups. – harrymc Jul 9 '10 at 21:13
@harrymc - I don't even have a .xlb file on my PC. (Tried Everything tool to search for it). I'll try the ApplicationData stuff now, since reinstall didn't help. – Shiki Jul 10 '10 at 7:48
@harrymc - No, doesn't help. Trying to capture and link a video about what happens maybe someone will come up with the right idea when he sees the video. – Shiki Jul 10 '10 at 7:52

This behavior can occur if you define names that indirectly refer to other nested names that are more than 20 levels deep. When you add or use a name that exceeds that level of indirection in a formula, you receive this error message. You also receive this error message when you delete a name that is referenced by more than 20 levels of defined names.

Check KB292471 for resolution.

share|improve this answer
The spreadsheet is really simple. No complex formula, no styling, nothing extra. It is only 300 line long, a few column wide. Just simple, pure, short data. Almost nothing. And it was able to work normally. Something went FUBAR I'm sure. Tried to delete AppData but nothing happens, it won't clear out my settings. Any idea how could I reset everything about Office? I don't really want to reinstall.. (It's an original 2007 Office Professional (or what.. orange color.) – Shiki Jul 9 '10 at 18:03
Did you try Office Repair? – Mehper C. Palavuzlar Jul 9 '10 at 18:45
I'll try. The disc is OEM so I have only a key. I'll ask the person in charge for the disk, hopefully tomorrow I'll be able to install it. – Shiki Jul 9 '10 at 19:22
OK, good luck... – Mehper C. Palavuzlar Jul 9 '10 at 19:36
Reinstalled it, the same thing happens. Any other idea? – Shiki Jul 10 '10 at 7:47

If it's related to Ditto then check the size of your Ditto.db.

As I reported here, the Ditto database grows without limits. Deleting it periodically helps.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .