Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

All of the guides I could find online were from 2004 and they no longer work. I am stumped.

Could someone create a step by step guide? I have Apache working, but PHP does not work.

share|improve this question
1  
You do not say what does not work. Did you install the php-mod for apache? –  txwikinger Jul 10 '10 at 0:36
    
This is really a Server Fault question. –  CarlF Feb 10 '11 at 18:25

1 Answer 1

It shouldn't be too complicated. Make sure you've done the following (or equivalent commands):

# Make sure PHP has the apache2 USE flag set
echo "dev-lang/php apache2" >> /etc/portage/package.use
# Install packages
emerge www-server/apache dev-lang/php

then edit /etc/conf.d/apache2 to include -D PHP5 in APACHE2_OPTS, (re)start Apache, and you should be good to go.

If you've accounted for all that, you'll need to provide more specific information about what problems you're having in the question, as txwikinger pointed out.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.