Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Right now I have a DVD in my laptop drive and the computer is hard at work trying to pry some readable bits from it. Judging by the sound of it, it is utterly failing.

But while I realize the futility of this current endeavor, my computer does not an will happily continue to inspect the disk for the rest of the week.

Now I would like to lift this burden from his metaphorical shoulders by just ejecting the DVD. However, the laptop sports a flashy slot-in DVD drive which sadly lacks an eject button. I know I could eject the DVD using the explorer but selecting the DVD in explorer will crash explorer. I also have a keyboard button that is supposed to eject disks, but right now it is not accomplishing anything.

So, is there any way of relieving the poor laptop of this thankless task or is my only option a restart?

Edit: Just waiting solved the issue. After about 20 minutes of dedicated concentration, the laptop finally gave up on the disk and disgustedly spat it out.

share|improve this question
    
See - superuser.com/questions/132087/… –  ChrisF Jul 10 '10 at 17:01
1  
Doesn't help answer this question, there is no eject hole thus this is not a duplicate question. –  Tom Wijsman Jul 10 '10 at 17:16
    
@Tom - are you sure? The same point was raised on that question, but the image I found showed an eject hole. –  ChrisF Jul 10 '10 at 17:19
    
+1 for caring for your poor laptop's thankless endevors. –  Chris Nava Jul 10 '10 at 17:23
2  
[fanboy] Here I thought Macs just worked... [/fanboy] –  Ivo Flipse Jul 11 '10 at 10:02

4 Answers 4

up vote 1 down vote accepted

Solution for Linux or Mac OS X users:

Go to a terminal and execute:

drutil tray open
drutil tray eject

This seems to just work in a lot of cases.

Easy Attempt for Windows users:

I also have a keyboard button that is supposed to eject disks,
but right now it is not accomplishing anything.

  • Put the laptop to sleep.
  • Wait for the disc to stop rotating.
  • Wake the laptop up.
  • The EJECT key should now work.

This suggestion came from: http://www.macosxhints.com/article.php?story=20060814211608242

It could be possible that the button only works in OS X though.

Harder Attempt for Windows users:

  • Put the laptop to sleep.
  • Use something that can't make scratches and try to lift the CD up through the hole.
  • Now try to pull the CD out of it.

Maybe it's just better to reboot, and if that doesn't help you will need support or you could try to repair it.

share|improve this answer
    
Yeah, maybe try a Linux LiveCD. Puppy Linux is small. –  Nathaniel Jul 10 '10 at 23:19
3  
Very late to the party, but I just read this and had to point out that @Nathaniel's suggestion isn't going to work so well when there's already a disk in the drive. Maybe a thumb drive though ;) –  Shinrai Apr 29 '11 at 22:09

Hibernate windows. This will safely save state, but completely power off the macbook. When you power it back on hold the trackpad button and the disc should eject before Windows is restored.

share|improve this answer

There is usually a small hole in the front of the drive. If you insert a paper clip into it, it should manually eject the CD/DVD, even with the machine turned off.

share|improve this answer
    
I am using a MacBook Pro. There is no emergency eject (that I know of). –  bastibe Jul 10 '10 at 17:03
2  
Most slot-in DVD drives sadly don't have such eject hole. :-( –  Tom Wijsman Jul 10 '10 at 17:07

In Windows, Right click on Start, left click on Explorer and then right click on your cd drive and left click eject.

share|improve this answer
1  
Surely you mean "Left click on Start"? –  hippietrail May 4 '11 at 14:51
    
@hippietrail no I'm pretty sure he means right click he just left out that in windows 7 the option is called "open windows explorer". This answer is also irrelevant since the OP stated right clicking on it in explorer causes it to crash... –  Kyle May 4 '11 at 17:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.