Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Vista SP2 and Skype 4.1.0.141.

I have "Start Skype when I start Windows" checked, but it's still not starting automatically. Is this a Skype bug, or something I can track down myself?

UPDATE: I've just upgraded from .141 to .179 and the problem is back, with the registry entry corrupted as before. Again, fixing the registry entry as described seems to have resolved it.

share|improve this question

7 Answers 7

up vote 6 down vote accepted

Well, I have a solution, but I can't see any way that the problem could have arisen, except for a buggy skype installer .

msconfig was listing the command to run as:-

"C:\Program Files\Skype\\Phone\Skype.exe"  /nosplash /minimized

Note the double slash in there bfore 'Phone'!

Changing the registry entry for HKCU\Software\Microsoft\Windows\CurrentVersion\Run\Skype to remove the extra slash fixed the problem.

share|improve this answer
    
Excelent. It was the problem for me as well (Vista x64). To make things harder, autoruns did not display the double backslash, only a single one, therefore I missed the problem. This time I have used regedit and the problem was obvious. –  Suma Nov 4 '10 at 10:11

Try putting a shortcut to Skype in your startup folder

C:\Users\[UserName]\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup
share|improve this answer

I had the same problem with Vista SP2. I used the same trick for when the Microsoft updates got stuck:

I deleted everything regarding Skype from the hosts.

  1. Navigate to the following location:

    Windows 95/98/Me:

    %Windir%
    

    Windows NT/2000/XP:

    %Windir%\System32\drivers\etc
    

    Windows Vista:

    c:\Windows\System32\drivers\etc
    
  2. Double-click the hosts file.

  3. If necessary, deselect the “Always use this program to open this program” check box.

  4. Scroll through the list of programs and double-click Notepad.

  5. When the file opens, delete all the (Skype) entries.

  6. Save.

share|improve this answer

Right click on Skype shortcut which is in desktop (OR) right click on "skype" which is in Start-->Program menu.. then,

"Select Properties -> Compatibility tab. Uncheck the option “Run this program as an administrator”. Save by pressing OK button."

It will fix 2 problems.

1. Auto start up of skype during system starts

2. Drag and Drop (send file) in the conversation window will work.

Regards, Pravin (pravinramasamy85@gmail.com)

share|improve this answer
    
I can confirm that this solution solves these two problems that appear in Skype when installed on Win7 Pro x64. I cannot believe it was this simple. –  Sorrow Sep 24 '12 at 19:18

Right click on Skype shortcut which is on the desktop (OR) right click on "Skype" which is in Start → Programs

In the Compatibility tab under "Run program in Compatibility mode" choose your version. If you are using Vista or Windows 7, then press apply.

share|improve this answer

Do

Run --> msconfig [enter]
startups tab
check on in skype check box
Ok
Restart your computer.
share|improve this answer
1  
Should be 'msconfig' rather than 'mstsc'. –  Tom Jul 31 '09 at 9:40
    
Tom: Yup. Corrected. Been a while, since I used Windows. –  Lakshman Prasad Jul 31 '09 at 12:30
    
Tried that - checkbox was already ticked... :-( –  Roddy Aug 5 '09 at 9:53

When installing Skype 4.1, its base library Skype4COM.dll (version of 2009) is being stored in ?:\Program Files\Common Files\Skype but old version of Skype4COM.dll (of 2007) had been stored in \Windows\system32. After disabling startup of the new version, Skype starts by means of old library. The records of both libraries are in registry at HKLM\Software\Microsoft\Windows\CurrentVersion\SharedDlls (all listed dlls run at Windows startup, old Skype4COM.dll runs as if disabled Skype).

The method of curing:

  • Exit Skype
  • Delete both records from ....\SharedDlls key
  • Restart in safe mode, delete old Skype4COM.dll from system32
  • Restart Windows (Skype must not start if it was diasbled in settings)
  • Run Skype manually and set option "run at Windows startup"
share|improve this answer
    
Maybe a different problem. I don't have the old DLL on my system. –  Roddy Dec 17 '09 at 13:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.