Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have always disliked spell checking (may have something to do with being confronted with the condescending grammar checks in Word years ago) and I always try to get rid of the irritating red underlines wherever I see them.

Recently I started testing ubuntu lucid lynx (10.04) as a desktop environment, and the red lines are bloody everywhere. No matter how much I google it, I can only find references for enabling spell checking in different applications.

How do I completely disable spell checking in gnome? Am I the only one who doesn't want it?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

It's going to be a per-app setting. No way around that, except maybe to uninstall aspell and ispell (but it could very likely break things):

sudo dpkg -P --force-depends aspell ispell

For Firefox: Edit -> Preferences -> Advanced -> "Check my spelling as I type"

For OOo: Tools -> Options -> Language Settings -> Writing Aids -> Options: Check spelling as you type

Those are probably the two big ones.

share|improve this answer
    
Doing anything with dpkg --force-depends is generally not a good idea, and apt will require you to resolve dependencies before any actions anyway. –  whitequark Aug 14 '10 at 4:05
    
I said it'd likely break things... Fair warning ;-) –  maco Aug 14 '10 at 4:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.