Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My Toshiba laptop worked perfectly for three months or so in Ubuntu recovery mode but now it hangs/freezes every hour and when it's plugged in.

I spend eight hours a day on an average on my laptop. I just want it to last at least that long. If the laptop is not plugged in in recovery mode/regular Ubuntu mode, it freezes in five minutes and the screen becomes all weird.

It works perfectly with Windows 7 on battery but hangs instantly as soon as it is plugged in. Also now, a high CPU usage doesn't help anymore.

Any strategy or suggestions that I could employ to extend the duration for which it doesn't freeze?

A post on the Toshiba forums, A205 S4617 laptop freezes when ac power plugged in., describes the same situation as I am in.

share|improve this question
up vote 1 down vote accepted

The thread My Toshiba A200 suggests the solution of :

Try changing the following setting in the bios setup, under the 'Advanced' tab Dynamic CPU Frequency:
Mode = Always Low (NOT DYNAMIC)
My laptop has been running on AC power without a problem for 24hours, including many restarts, and when I went back to the original bios setting, the problem returned almost straight away.


Other suggestions I found on the web from here and here:

  1. Set the power plan to high performance
  2. Set the power plan to "Minimal Power Management" (1 and 2 do conflict)
  3. Start -> Control Panel -> Device Manager --> Processor -> disable one of two processors -> reboot normally
  4. Do this:
  1. Only plug battery into laptop
  2. Turn on the laptop and start Windows normally
  3. Plug AC adapter into laptop, the screen will freeze
  4. Leave the laptop the way it is for 12-24 hours
  5. After 12-24 hours, turn it off the hard way
  6. Once it is turned off, turn it back on. The laptop is working now.

Other sources blame the graphics card for the problem, and claim that degrading the display solves the problem. To check this out, boot into Safe mode (which doesn't use the advanced video driver) and plug it into the mains. If this is indeed the case, turn off every advanced display option such as as Aero, themes or whatever.

share|improve this answer
doesn't work anymore. Worked when problem first appeared. Thanks for the efforts put in. – tapan Jul 14 '10 at 21:37
@tapan: See my edit. – harrymc Jul 16 '10 at 20:49
I tried the high performance thing on windows 7 and it seems to be working for now. Its been 3 hours now without a problem. Seems like a good fix for now. I would really appreciate it if you could suggest something similar for ubuntu (which is my primary operating system). I'm going to keep the question open for a while to see if i get any answers for ubuntu. However I feel you earned the bounty for all that work you put in. Thanks a lot :). – tapan Jul 17 '10 at 1:58
@tapan: I don't use Ubuntu, but you can maybe find power management under System/Preferences/Main Menu/System Tools, or gnome-power-management. See also this:… – harrymc Jul 17 '10 at 7:04

You might want to consider that it is getting too hot and causing a board inside to malfunction. My Toshiba Satellite gets HOT when plugged in, so I charge it and run it from battery when possible. Have you tried just charging each time you need it, then unplugging it and then repeating as necessary? I know you said you are on a laptop 8 hours a day, but perhaps this could help.

share|improve this answer
The problem is not the heat. All toshiba satellites manufactured sometime in 2007 develop this defect in 2 years. Something which is clear from the forum post i have linked. So it is definitely a hardware issue. All i need to figure out is how to make my laptop last longer without freezing. Charging each time i need my laptop is currently my last option :). – tapan Jul 12 '10 at 11:16

I had the same problem, the laptop continually froze constantly during start up. I didn’t click that it was every time I was on the mains power and when I was on battery it was fine. Eventually I put 2 and 2 together and I set the power plan to "Minimal Power Management" and the Laptop is working fine now.

share|improve this answer
same as harrymc's answer? – JoshP Dec 3 '12 at 19:06

You must log in to answer this question.

protected by Community Oct 11 '11 at 8:02

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .