Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a computer running Windows 7 x64 with file sharing enabled. The problem is that I am unable to browse the available shares on the computer from any other computer or network media player.

File sharing used to work just fine, but I just recently noticed that it stopped working though I didn't change any sharing or networking settings.

If I browse to \\COMPUTERNAME, I get "Access Denied" immediately. However, if I type in the full UNC path to a share I know that I have, \\COMPUTERNAME\Users\Public, it connects and works.

This is a big issue because my networked media player will try to browse the available shares on a computer name, I cannot put in the path. It prompts for credentials, but even after supplying the correct username and password, it still gets the access denied message. On Windows computers, I do NOT receive the prompt for credentials.

In Advanced Sharing Settings I have:

  • Turn on network discovery
  • Turn on file and printer sharing
  • Turn on ... public folder
  • Enabled 40 or 56-bit encryption
  • Turn off password protected sharing

For good measure, I have the firewall disabled during my tests. I even tried disabling sharing, rebooting, and re-enabling it, but that didn't fix it either.

share|improve this question
add comment

3 Answers

I recall seeing another question earlier that said that he "had forgot to bind Windows File Sharing to the network".

Edit: Here is the link: http://superuser.com/questions/162744/sharing-a-folder-with-win-2k3-only-allows-localhost It is Windows Server 2003, though...

share|improve this answer
add comment
up vote 0 down vote accepted

I was able to solve this problem with by enabling anonymous access to browse shares.

  1. Open gpedit.msc
  2. Go to Computer Configuration -> Windows Settings -> Security Settings -> Local Policies -> Security Options
  3. Disable,
    1. "Network access: Do not allow anonymous enumeration of SAM accounts and shares"
    2. "Network access: Do not allow anonymous enumeration of SAM accounts and shares"
    3. "Network access: Let Everyone permission apply to anonymous users"
  4. Go to "User Rights Assignment"
  5. Add user "Everyone" and "Guest" to "Access this computer from the network"

That allows my shares to all be visible and to be accessible without credentials for all shares with "Everyone" permissions.

share|improve this answer
    
This does compromise your security on the file share though –  baldy Jun 9 '11 at 6:55
add comment

I've recently had the same problem, and after a lot of digging found the Credential Manager in Windows 7 Control Panel to be the culprit, somehow my credentials got corrupted in there. I deleted the saved credentials for each of the machines I had problems browsing, reconnected to each, and problem solved.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.