Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to add in

colorscheme desert

at the bottom of my _vimrc file within Windows 7 and when trying to save it, I keep getting "Access Denied". I set my HOME variable to the "C:\Program Files (x86)\Vim" but still no luck.

share|improve this question

migrated from stackoverflow.com Jul 12 '10 at 0:54

This question came from our site for professional and enthusiast programmers.

    
Hmm...I figured it out. I just had to add special permissions to my user group. –  CoryDorning Jul 11 '10 at 0:23

2 Answers 2

To run a program as administrator hold down Ctrl + Shift when you open it. This might give you the permissions to do what you want to do.

share|improve this answer
    
thx for the tip, but the option isn't available for the file itself and when opening it from Vim (under admin) still didn't have any luck. –  CoryDorning Jul 11 '10 at 0:22

Don't save your user preferences in Program Files, save them in your $HOME directory, which should be set to C:\Users\username (or similar).

share|improve this answer
2  
+1 and especially don't set your HOME variable to C:\Program Files\anything. –  Greg Hewgill Jul 12 '10 at 1:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.