Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When you open Outlook (2003/2007) hooked up to an Exchange server, sometimes you are prompted for network credentials. Sometimes it is because you opened it before the network/VPN connection was up or maybe it's just a glitch in Outlook.

For some reason, it keeps defaulting to exchange server\user instead of domain\user - which is required to log on.

e.g. EXCHSERVER01\username ;-(
instead of DOMAIN\username :-)

Not only is it very annoying, but it prevents technically challenged users from logging into Outlook because they never know to change it to the domain name.

Anyone know of a fix, maybe a change of setting within Outlook that will prevent this from happening and always try to log on with domain\user credentials? Not really fussed if the credentials box continues to popup, it's trying to make it default to domain\user.

share|improve this question

3 Answers 3

up vote 1 down vote accepted

I've been thru that so many times and how I fixed that issue is quite simple. I just needed to go in AD and reset user's password. Then, the user needed to log off and log back in. The connection with Exchange was quick and no username/password were required.

Give it a try, it takes 2 minutes and worked for me all the times.

share|improve this answer
    
Will also try this... thanks. –  Kez Oct 14 '10 at 14:48

This article should fix your issue: http://support.microsoft.com/kb/956531

Download the hotfix To enable the hotfix, follow these steps:

>    1. Exit Outlook 2007.
>    2. Start Registry Editor.
>           * In Windows Vista, click Start
>             Collapse this imageExpand this image
>             the Start button
>             , type regedit in the Start Search box, and then press
> ENTER.
> 
>             Collapse this imageExpand this image
>             User Account Control permission
>             If you are prompted for an administrator password or for
> confirmation, type the password or
> provide confirmation.
>           * In Windows XP, click Start, click Run, type regedit in the
> Open box, and then click OK.
>    3. Locate and then click to select the following registry key:
>       HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\RPC
>       Note If the RPC key does not exist, follow these steps:
>          1. Right-click the Outlook key, point to New, and then click Key.
>          2. Type RPC, and then press ENTER.
>    4. After you select the key that is specified in step 3, point to New on
> the Edit menu, and then click DWORD
> Value.
>    5. Type UseWindowsUserCredentials, and then press ENTER.
>    6. Right-click UseWindowsUserCredentials, and then
> click Modify.
>    7. In the Value data box, type the value that you want to use, and then
> click OK.
> 
>       Note When you set the UseWindowsUserCredentials value to 1,
> only the user's desktop credentials
> will be used. The following scenarios
> may help you determine the value that
> you want to use.
>           * Account: Domain
>             UseWindowsUserCredentials: 0 (or not present)
>             Protocol: TCP, HTTP with NTML authorization
>             Result: Connect to Microsoft Exchange without prompting
> for user credentials.
>           * Account: Non Domain
>             UseWindowsUserCredentials: 0 (or not present)
>             Protocol: TCP, HTTP with NTLM authorization
>             Result: Prompt for user credentials and connect to Microsoft
> Exchange.
>           * Account: Domain
>             UseWindowsUserCredentials: 1
>             Protocol: TCP, HTTP with NTLM authorization
>             Result: Connect to Microsoft Exchange without prompting
> for user credentials.
>           * Account: Non Domain
>             UseWindowsUserCredentials: 1
>             Protocol: TCP, HTTP with NTLM authorization
>             Result: Does not prompt for user credentials, and will not
> connect to Microsoft Exchange. Remains
> in the disconnected state,
> occasionally trying to connect.
>           * Account: Domain
>             UseWindowsUserCredentials: 1
>             Protocol: HTTP with Basic authorization
>             Result: Prompts for user credentials and successfully connects
> to Microsoft Exchange. Additionally,
> it will continue to prompt you if you
> mistype your password.
>           * Account: Non Domain
>             UseWindowsUserCredentials: 1
>             Protocol: HTTP with Basic authorization
>             Result: Prompts for user credentials and successfully connects
> to Microsoft Exchange. Additionally,
> if you mistype your password, it will
> continue to prompt you.
>           * Account: Domain
>             UseWindowsUserCredentials: 1
>             Additional Steps: When you configure the profile, select Always
> prompt for username and password.
>             Result: Prompts for user credentials and successfully connects
> to Microsoft Exchange.
>    8. On the File menu, click Exit to exit Registry Editor.
share|improve this answer
    
Hmm thanks, I initially saw the word "RPC" and figured the article only applied to RPC over HTTP connections - but looks like I might be wrong. Will try this when I get home. –  Kez Oct 14 '10 at 14:47

The problem was Outlook had picked up rogue "RPC of HTTP" settings during the setup of the account on the computer. I went into the account settings, into the Connection tab, unticked 'Connect to my Exchange mailbox using HTTP' and restarted Outlook. Instant fix.

Saying that, this fix is only for Outlook 2007 - so I have only really answered half my question :\

alt text

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.