Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've installed the drivers from nVidia. When I go into the NVIDIA X Server Settings application, in the X Server Display Configuration setcion, and click the "Configure" button, "TwinView" is disabled. Also, clicking "Detect Displays" doesn't pick up my monitor (which is connected through a port replicator - keyboard and mouse in that port replicator work fine).

Has anyone else seen this? Is this just a limitation of the current nvidia linux drivers?

share|improve this question

migrated from Jul 12 '10 at 14:57

This question came from our site for system and network administrators.

Just for posterity, I have a E5410 and Fedora14 works fine for using both the DVI and VGA outputs from the dock simultaneously. You can even enable the laptop panel as well for triple display if you want.

That said, it's a little bit flaky when switching back and forth between docked and not docked. Sometimes it gets stuck on the laptop panel when it should be using the external monitors. In that case something that worked for me was to switch to a text console (ctrl-alt-f2) and wait a few seconds then switch back to X (ctrl-alt-f1). That seems to reset things and it works properly again.

share|improve this answer

TwinView only works if both monitors are connected to nVidia video cards (possibly the same video card, not sure about that), and nvidia has been known to have problems with Xinerama in the past. Try with nv instead.

share|improve this answer

Thanks, Ignacio. It actually turns out that I didn't have to do anything so severe as that. Here's what turned out being the issue:

The Latitude E6410 has only VGA output, but my docking station has both DVI and VGA output. I was trying to use the DVI output on the docking station. Fortunately, my external monitor has both inputs, so once I switched to a VGA cable, it worked fine.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.