Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I ran into a problem the second after installing Windows 7 a few months ago, but it only affected a few applications at the time, so I ignored it. Now an increasing number of applications behave the same way and it's annoying. The DPI settings seem to have an issue as can be seen below:

Bad

The same application should look like this:

Good

The DPI is set to 100% (I tried changing it but it had no effect). I think perhaps the Regional / Language settings have something to do with it but I can't turn it off to English only.

Any ideas?

share|improve this question
    
I'm not allowed to have two links in the description. But for example this is how the program normally should look: c.ask.nate.com/imgs/qrsi.tsp/8861288/11823503/0/1/A/01.jpg (dont mind the windows classic theme, it happens on all themes) –  Anonymous Jul 12 '10 at 15:56
    
What is your screen resolution? –  Nicu Zecheru Jul 12 '10 at 16:01
    
1024x768 (....) –  Anonymous Jul 12 '10 at 16:32
    
You could right-click on the Shortcut to the program and choose properties. Under the Compatibility tab, check "Disable display scaling on high DPI settings." Click OK and start the program. Does this fix the problem for that program ? –  harrymc Dec 7 '12 at 17:05
add comment

3 Answers 3

This is a known bug that affects users with a high resolution display.

During installation, Windows 7 installs a larger font set which is 125% of the normal size. If you then choose go back to the standard font size (100%), Windows will keep some of the large fonts even though everything else is adjusted for standard fonts, causing some programs to display incorrectly as the DPI is too big for the window size.

  1. Open the Start menu and type regedit and press Enter.
  2. Locate the key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts
  3. Find the value MS Sans Serif 8,10,12,14,18,24
  4. Change from SSERIFF.FON to SSERIFE.FON
  5. Find MS Serif 8,10,12,14,18,24
  6. Change from SERIFF.FON to SERIFE.FON
  7. Find Courier 10,12,15
  8. Change from COURF.FON to COURE.FON

Restart Windows and the problem should be resolved.

share|improve this answer
    
Nailed it. Thank you. –  Fopedush Dec 14 '12 at 19:48
    
The pleasure's all mine. –  Ian Atkin Dec 14 '12 at 20:00
add comment

Right-click on the desktop, click on Personalize > Window Color > Advanced appearance settings and change the font sizes there. Or you could just set everything to the default theme and see what happens.

share|improve this answer
    
I can't speak for the original asker of this question, but it appears he tried changing the DPI using this approach and set it to 100%, only to have certain programs still scale too large. –  Fopedush Dec 7 '12 at 16:14
add comment

I am using Windows 7 32 Bit SP1, I have downloaded the application MemSet4.1, and it comes all fine on my screen. Changing the DPI settings doesn't have any impact on its display. Changing screen resolution also doesn't cut off the content, as you have shown in your screen. Even working with different languages doesn't have any impact on output. In all such cases, I get the correct result, so, in fact I don't see the issue on my machine.

I think, you should look for the Display driver installed in your machine, and if correct driver is not installed and default from windows is used, then you need to install the correct display driver.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.