Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Notepad++ is a great editor... the Regular Expression facility is stunted, but I can live with that. It is ok for most find/replace situations, and for the occasional others I'll just hop across to UltraEdit(Unicode) or TextPad(ASCII only).

However, I can't live without a Hex Editor on tap!

The Notepad++ HexEditor plugin seems to work fine... I use it frequently.
For some reason unknown to me, this plugin is forcibly disabled by Notepad++ whenever I upgrade to the latest version (of Notepad++), with a message something like ".. due to instability issues".
HexEditor.dll gets moved into a "quarantine" subfolder: .\disabled.

This sounds a bit ominous. I have searched high and low, and have found nothing which makes any reference to this mysterious "instability". The plugin is available on the Notepad++ plugins page (which lists third-party plugins, and is not, strictly speaking, a Notepad++ page), and there is no mention of instability.

What's going on? Does it randomly get it wrong and corrupt data? Does it crash Notepad++?

Can I trust this plugin?

share|improve this question
    
Interesting question? Could it be that the problem was fixed on plug-in side and the Notepad++ side wasn't notified of it? In the end, you could always ask developers why is the plug-in tagged incompatible. –  AndrejaKo Jul 13 '10 at 11:48
    
A Google search for Notepad++ HexEditor instability finds a thread (number 2 only to this Super User question) which suggests HexEditor "can crash Notepad++ in some rare cases". –  Bavi_H Jul 14 '10 at 4:04
1  
...And here's a relevant-looking bug tracker search for open HexEditor bugs: Notepad++ Plugins - Tracker: Bugs - Open - HexEditor –  Bavi_H Jul 14 '10 at 4:16
2  
Thanks for the comments. I've been to Notepad++'s Sourceforge forum, and found some entries. 2009-12-09 HexEditor v0.9.5 vs N++ v5.6.1 2009-09-25 Hex editor 2009-09-11 Hex-Editor v0.9.5 available It seems safe data-wise, with some display bugs which they're working out.. Good enough for me, as my main concern was the question of data corruption. –  Peter.O Jul 16 '10 at 16:49

5 Answers 5

up vote 4 down vote accepted

The Hex Editor plugin was disabled for being unstable. This means that the plugin crashed Notepad++ in some situations. I encountered this problem myself when trying to save an edited file.

Earlier versions of Notepad++ don't have those problems with the plugin.

share|improve this answer
    
Thanks for the comment... Perhaps I was using it in a way which didn't trigger the bug.... In the 10 months since I asked the question, I've worked around the issue by using Emacs as my "serious" editor... (actually I've shifted camps entirely to Ubuntu, where I can still use Notepad++; running in wine.. :) –  Peter.O May 18 '11 at 15:16

Some plugins are disabled by notepad++ when you upgrade it :/. One of my favorite diff plugins got disabled a while back and I have had to get a earlier version of notepad++ to cope.

share|improve this answer

Just put it back in the plugins folder and it works fine.

share|improve this answer

I too like the HexEditor plugin. I rolled back Notepad++ to older version to be able to work with this plugin. Now I checked the latest version on Notepad++ (v5.9.2 unicode) with the latest HexEditor plugin (v.0.9.5 unicode) and it works! The plugin is no longer disabled.

share|improve this answer
    
It's available but the Stability still says there are reported problems. –  PPC-Coder Jul 22 '11 at 15:23

Simply copying HexEditor.dll back from disabled to pluggins folder solves the problem. I haven't come across any crash.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.