Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

advanced file and printer sharing A can do it on B but B can't on A, it prompts for user/pass

I have 2 computers. Both Win XP Pro

Both advanced file sharing.. I want that.

But when I connect comp A to Comp B, (start..run..\B) I get a user/pass prompt. B can view folders on A though start..run..\A.

The problem is A to B.

If it helps.. I created duplicate user accounts on each computer. But I not logged in as the same one. eg. on comp A i'm logged in as nameQ, on comp B logged in as nameR compA has an account nameR, and compB has account nameQ

share|improve this question

2 Answers 2

up vote 1 down vote accepted

solution was one of the netsh commands.

netsh winsock reset catalog

netsh int reset all

netsh ip reset c:\resetlog.txt

some other symptoms of the problem I was able to find.. that may help diagnose the same problem Besides, when trying to do \compblah "\compblah is not accessible. You might not have permission to ue this network resource. Contact the administrator of this server to find out if you have access permissions. Multiple connections to a server or shared resource by the same user, using more than one user name, are not allowd. Disconnect all previous connections to the server or shared resource and try again""

net view \computername net use Z: \computername\sharename

net view. Gave.error 5 (apparently there are various error 5 messages one can get. I know I got error 5 though) net use Gave error 53 I didn't jot the text of them down at the time and it's fine now so I can't see what they were. But now net view \computername net use \computername
both don't give errors. The netsh commands(one some or all of them) fixed it.

a good site is michna's http://winhlp.com/wxnet.htm though I do suggest still if solving it from that, putting the ans here too so it's not just on one site!

Another symptom of the problem, which is now cleared up, is sysinternals psloggedon, gave an error.. "Error opening HKEY_USERS for \compblah ...Unable to query resource logons "

that is now fine.

apparently many "assymetrical problems" can be FW or 3rd party FW or remnants of, but not in this case since I don't have 3rd party FW. Win FW with exceptions put in,was fine.

net use * /D (clearing the cache helped in my testing) appaerntly it can get rid of shares.. but my shared folders seem fine after it. IT was a useful command 'cos it meant that if I logged on successfully as say Guest(not really what I want), then it wouldn't keep going in automatically as it, it would prompt again. so that just helped a bit in testing things.

ther is LSP Fix and WinsockXPFix from http://www.cexx.org/lspfix.htm though I didn't try them..

as mentioned, solution was netsh winsock reset catalog netsh int reset netsh ip reset c:\resetlog.txt

and if any of those, it was probably the first one of those 3 commands that solved it.

share|improve this answer
this was an absolutely brilliant solution! those 3 netsh commands are very important! –  barlop Sep 23 '10 at 11:10
hanselman.com/blog/… –  barlop Jul 20 at 9:46

When it prompts for user name/pass does it not accept them? Make sure the password is what you think it is. It's possible you mistyped on one computer when you set up the account. If you want it to not ask for your user/pass when you connect, you need to either log on to the local computer as a user (with identical name and pass) to an account that exists on the remote computer, or, once you've established a connection, use the

net use \\server\share /persistent:yes /savecred

command to have it remember.

share|improve this answer
"When it prompts for user name/pass does it not accept them?" correct, it doesn't. It doesn't keep prompting though, I find it gives this error message "\\compblah is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions." –  barlop Jul 14 '10 at 3:42

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.