Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I use NirCmd ( to enable me to run commands such as "power off the monitor", "mute system volume" from the command-line (and I highly recommend it, BTW). My OS is Windows Vista.

I want to use it to power off my monitor in a certain time. So I'm using Windows Task Scheduler's CLI shortcut, "at":

at 00:30 "nircmd monitor off"

The task indeed gets created (it shows up in "control schedtasks"). But it doesn't have the desired effect. I must say, running just "nircmd monitor off" indeed powers the monitor off (I disabled my UAC, so everything I run from the Run window or any prompt is elevated).

So, my first guess is that it's not running nircmd with elevated privileges. How do I solve this?

Also, I tried two simple tests to make sure the "at" command works as expected:

at 13:21 calc
at 13:22 /interactive calc

The calculator doesn't show up in any of them, but if I go to Task Manager and list the processess of all users, it indeed is there, started by the user "SYSTEM".

So, any tips on how to approach this situation would be useful.

share|improve this question
up vote 1 down vote accepted

I see the following dialog when creating a new task (note: I chose "new task" rather than "new basic task"). I would suggest running it whether or not the user is logged on, and with the highest privileges (you might also need to choose a different account with which to run the command if your account is not an administrator). Does this work for you, or did you already have these settings selected?

alt text

share|improve this answer
Just tried doing that, selecting the settings like in the picture, but doesn't "work" either. The nircmd task does get created, does run (it says it "completed successfully") but the desired action doesn't happen. – Rafael Almeida Jul 13 '10 at 20:56
With a few tweaks, I actually got it to work. I'm trying to get it to work via command-line with "schedtasks" now, but I can handle it from now on. Thanks! =) – Rafael Almeida Jul 14 '10 at 2:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .