Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a D-Link DSL-2650U ADSL router for my home network.

I also have my own domain server registered at, and I have successfully configured my router to keep [mydomain] pointing at my router's public IP address.

I have also successfully used NAT to redirect Windows Remote Desktop calls to the desired computer.

Now I'm setting up a web site on one of the computers in my network, and I want all HTTP requests sent to [mydomain] to be forwarded on to that computer. Should be easy, right? But it doesn't seem to work. My web site is set up on port 800, so I set up NAT to forward calls on port 800 to my local computer. Try browsing to http://[mydomain], and it doesn't recognize the address. I tried forwarding port 80 to port 800 on the local computer, and when I navigate to http://[mydomain], instead of going to that web page, it goes to the router's admin page.

It seems that the router is ignoring the NAT setting for port 80 (and 800 for that matter) - what's the secret switch to get this working?

share|improve this question
up vote 3 down vote accepted

Try doing this from a computer outside your own network. Most routers don't resolve internal/your own domains/IP's.

share|improve this answer
Spot on! I browsed to [mydomain] from outside the network, and it worked perfectly! Thanks! – Shaul Behr Jul 14 '10 at 13:57
@Shaul - You're very welcome! – BloodPhilia Jul 14 '10 at 16:06

Check if there is a setting to disable external (from outside your network) remote access to your router's admin panel. And do recheck the NAT forwarding.

EDIT: Plus, you might also have to wait for the DNS settings to propagate through all the networks - it usually takes half an hour to hour and a half. And usually people don't touch their router's NS settings just letting the system automatically adjust to what's on the 'Net

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.