Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The computer is a Dell Vostro 220 Slim Tower (regular tower.) When the power button is pressed, the computer exhibits the following behavior:

  • No lights turn on
  • No noise is heard
  • No fans turn at all
  • Monitor says "No Signal Connected"

The computer was on an APC battery backup, so this was not caused by an electrical anomaly as far as I know.

What I tried:

  • Replaced power supply
  • Replaced power cord
  • Plugged into completely different outlet (w/o battery backup)

None of these things changed the situation.

Is it the motherboard? Or could it be the RAM/CPU?

share|improve this question
7  
This is stupid, but check if power button if correctly connected to motherboard and if it is working correctly. I've seen a computer with malfunctioning power button and the problem was really difficult to solve. It's just that no one ever thinks it can stop working. –  AndrejaKo Jul 14 '10 at 15:47
    
I appreciate all of the comments. Replacement motherboard arrived and I will be doing the installation soon. Will let everyone know what happens and mark an answer. Thanks again. –  James Watt Jul 25 '10 at 3:12

7 Answers 7

up vote 9 down vote accepted

I'm pretty sure it's the MB, because CPU problems should make "beep" error sounds. Since you'r not having any "beep" sounds - the MB is the main culprit.

share|improve this answer
    
Replaced motherboard, it works like a charm. –  James Watt Jul 26 '10 at 14:38
    
@matan-eldan doesnt Ram issues causes beep error sound? –  iamcreasy Mar 11 '12 at 0:07
    
@iamcreasy - not necessarily. –  Matan Eldan May 23 '13 at 7:34

If absolutely nothing is happening I tend to suspect the mobo because even if there's nothing connected pressing the power switch should send a signal to the PSU that would turn on case fans, etc.

The ram is almost certainly not to blame (although if the mobo failed catastrophically it could have been fried too), because a good board with a working CPU should produce a post error code indicating a ram problem.

share|improve this answer
1  
I would have marked this one as the answer, but Matan had his answer in first and mentioned how the mobo would have beeped if the RAM was bad. I still up voted your suggestion though, because it was close. –  James Watt Jul 26 '10 at 14:37

When you say "replaced power suply" it means that you changed the ATX power supply, doesn't it? Did you correctly connected the wires of ATX power supply? If "yes" and "yes", then the problem must be motherboard.

share|improve this answer

Since you have already replaced the power supply, the problem is presumably something that's causing the power supply to shut down the instant you turn it on, The problem could be the motherboard or it could be one of the drives. If you are comfortable working inside the computer, you could try removing the power (and corresponding signal cables to be safe) from any hard drive, CD/DVD drive, etc. (i.e. everything except the motherboard) and see if that makes a difference. On the other hand, the problem could be that the power supply is not being turned on because of a bad power switch, broken wire etc. though this seems less likely.

share|improve this answer

Most (9 out of 10) systems will

  • have a small LED somewhere on the MB that is on when the power is connected (even if the system is powered off).
  • have blinking lights in the (onboard) network adapter if the power is connected and a network cable is attached that is connected to a switch or other system.(even if the system is powered off)
  • make beeping sounds if the memory or cpu is dead... but that does require an old fashion speaker to be attached and only happens iff the system is being powered to boot.

Now because your system apparently does none of this my assessment is that the mainboard is not getting powered. This implies that either

  • your mainboard is seriously broken (which may also cause the next item on my list).
  • your power switch (the signal goes through the mainboard !!) is broken (or connected badly to the mainboard) --> the power supply simply doesn't receive the signal to start powering the system.
  • your power supply is not sending power (i.e. dead or not started)
  • or the connection between the two is dead. (i.e. check all connectors).
share|improve this answer
    
Surprisingly, this motherboard doesn't have an LED indicating power. Strange... –  James Watt Jul 26 '10 at 14:39

I'm posting this answer for people who have similar problems. I recently had the same problem and it seems to have turned out that scratches on the place where you place the motherboard was causing a short which prevented boot.

share|improve this answer
    
I don't understand how this could be possible. The motherboard doesn't sit directly on metal that could be scratched... it mounts to pegs that mount to the case. –  James Watt Aug 17 '10 at 13:08
    
I know, but that's what's been happening to my computer lately. It's more related to the aftermarket cooler I installed having screws that extend that far down than the motherboard itself. I'm just saying that's what seems to have been causing my problems. I hardly believe it myself. –  indyK1ng Aug 18 '10 at 2:54

i had issues since wednesday with my new M5a97 and FX-8320 , no vga output no indication of anything working except fans and a few lights, it turned out one of my ram's is broken or misfunctioning i tryed both on all possible configurations, and turned out one worked and the other didnt. at first i thought it had to do with the nw mobo and new cpu. then i thought it was my older vid card and my even older psu.. turned to be one of the new ram's

so my advice, try the ram on any possible way, just one. slot 1 - 2- 3 -4 etc took me a day but now its now booting!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.