Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am running Ubuntu 10.04 LTS. When I boot up the computer it goes to the splash but there is no login screen, just the purple background and the mouse cursor. "Checking battery state" is the last line that does not have an "[OK]". When I press Ctr-alt-shift-F1 I can login and sudo stop gdm and startx. However this makes it so that the applets don't show.
Error: "The panel encountered a problem while loading "OAFIID:GNOME_notificationAreaApplet" and does it for every single applet. Everything else works fine though.

I get a EHCI: BIOS handoff failed twice in the dmesg as well.

The laptop has intel mobile integrated graphics.

UPDATE: Now my desktop has the exact same problem.

Things that I have tried: Changing to GRUB_CMDLINE_LINUX_DEFAULT="i915.modeset=1 acpi=off"

share|improve this question
Have you tried unchecking Power Manager (or Power Management or whatever it is) from the startup items? – jrc03c Jul 14 '10 at 19:57
Yes I have. I've also tried most of the fixes here Doesn't seem to work. – jeffhsu3 Jul 17 '10 at 19:34

To anyone that have this issue: How much free space do you have on your Hard drive? Too little space can cause Gnome power management to stop. Try to free some space using a live cd (let´s say 5 gb) and reboot your machine. Now it should start normally.

share|improve this answer

I know this is out of date, but for the next person with a *buntu that hangs at "Checking Battery State ... [OK]": Ctrl+Alt+F1 to login to terminal, then:

sudo apt-get --reinstall install gnome-power-manger

followed by a restart, worked for me.

Just reinstalls the default configuration for gnome-power-manager, which was apparently causing the problem.

share|improve this answer

If you have GRUB2 bootloader, you can edit the boot parameters to turn ACPI (and thus the message) off.

After it hangs on "Check Battery State," press Ctrl-Alt-F1 to enter a terminal. Log in, then open up nano to edit the GRUB2 configuration file: sudo nano /etc/default/grub

Search for GRUB_CMDLINE_LINUX_DEFAULT and correct it to be GRUB_CMDLINE_LINUX_DEFAULT="acpi=off".

Save it by pressing Ctrl-O and update the bootloader with the new settings: sudo update-grub

Then reboot:sudo reboot

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.