Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I cannot write to the mounted directory on wwwdev as root. I can of course access it from my mac.

I have mounted the directory

  • from my Mac Darwin Radeks-iMac.local 10.2.0 Darwin Kernel Version 10.2.0: Tue Nov 3 23:08:29 PST 2009; root:xnu-1486.2.11~3/RELEASE_I386 i386

  • to our server Linux wwwdev 2.6.22.19-0.1-default #1 SMP 2008-10-14 22:17:43 +0200 x86_64 x86_64 x86_64 GNU/Linux

mount give me this radek:/Users/radek/Sites on /srv/www/htdocs/imacs/radek type nfs (rw,addr=10.0.0.210)

http://img35.imageshack.us/img35/2742/permissionsr.png

click for better image quality here

update

  • not sure if it matters but we use automount.

  • copy from the output of mount command

radek:/Users/radek/Sites on /srv/www/htdocs/imacs/radek type nfs (rw,addr=10.0.0.210)

wei:/Users/wei/Sites on /srv/www/htdocs/imacs/wei type nfs (rw,addr=10.0.0.203)

share|improve this question
    
sorry not to mention that every body else can write to somebody's else dir except mine. For example Wei's settings looks the same to me but I cannot write under my directory as root from wwwdev but I can under his directory –  Radek Jul 15 '10 at 5:18
add comment

2 Answers 2

up vote 1 down vote accepted

It looks like 'root_squash' is on on the NFS server. This is an option defined in /etc/exports that you should turn off if you plan on having the root user write data to that directory. That's a guess assuming that there is a third machine (the NFS server) or the directory on the Linux machine is NFS mounted to itself.

Another thing that's going to cause you trouble is that the users UIDs don't match between machines. That will make permissions-keeping / file access control challenging at best.

share|improve this answer
    
I will check this out when admin comes to work next week ... –  Radek Jul 16 '10 at 1:43
    
we added radek -rw,no_root_squash radek:/Users/radek/Sites to /etc/auto.imacs but it didn't help –  Radek Jul 20 '10 at 1:22
    
What is the significance of the differing IP addresses in the 'addr=' options for the two mounts? Are you looking at different servers, or different clients? If the former, are you sure the /etc/exports are configured the same between them? If the latter, have you tried your test from another client? –  Slartibartfast Jul 20 '10 at 4:10
add comment

I used -mapall=.... on my machine (=nsf server) in /etc/exports and everything works fine now. wwwdev although it is a development server :-) is nfs client in that case. Thank you for your help!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.