Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

if i hit any key,my keyboard is showing wrong character on the screen. i dont no whats wrong with it. my operating system environment is win XP. if i hit j it shows A and similarly for other characters too. what could be the problem

share|improve this question
See… – ChrisF Jul 15 '10 at 11:20
Are you sure it's not the keyboard itself? Have you tried a different keyboard on the box? – Daniel R Hicks Apr 8 '12 at 19:00

What is your keyboard layout set to? If you don't know how to figure it out, go to start->settings->control panel->regional and language options. Check that everything is set correctly on regional options tab. Then go to languages tab and click on details. Text services and input languages window should show. There make sure that under installed devices you have your keyboard layout.

Also, could you please type a row of letters on your keyboard? For example press qwertyuiop[] and paste it here so we can see what it shows. We might guess the layout from it.

share|improve this answer
ya sure, i will check and get back to you as the earliest.. Thanks again.. please help me to resolve this issue. – Shadow Jul 15 '10 at 11:38
I'll do my best! Make sure you reed ChrisF's answer to that other question! It too could be related. – AndrejaKo Jul 15 '10 at 11:55
one more doubt, if it is layout problem i need to make it for English US right? if so how to delete the existing layout? it requires any additional software? – Shadow Jul 15 '10 at 12:19
No additional software needed. You'll get in Text services and input languages a list of installed layouts. You'll also have add and remove buttons and default drop-down menu. Simply select US as default and use remove button to remove unnecessary layouts. Next time you start your computer, it'll use US layout. If you don't have US layout, use add to add English United States. You may have several options, but there should be one which will say just US. Select that one. – AndrejaKo Jul 15 '10 at 12:27
Defaulting ALT + SHIFT to change keyboard layout is really annoying. These "What does my keyboard do?!" errors are too common. – Jens Jul 15 '10 at 14:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .