Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have run the command

sudo rsync --chmod=a+rwx testfile testfile2

This creates a file testfile2 but the permissions on it are 755 (-rwxr-xr-x)

Can someone explain how to make it so the permissions are 777 (-rwxrwxrwx)?

share|improve this question

1 Answer 1

Use

sudo rsync --perms --chmod=777 testfile testfile2

or

sudo rsync --perms --chmod=a+rwx testfile testfile2
share|improve this answer
    
yup, from man page: The resulting value is treated as though it were the permissions that the sending side supplied for the file, which means that this option can seem to have no effect on existing files if --perms is not enabled. –  Nerdling Jul 15 '10 at 14:49
    
@Nerdling - Exactly... –  BloodPhilia Jul 15 '10 at 15:02
    
I get Invalid argument passed to --chmod (777) with the first option. Seems to be explained here? –  Jack Douglas May 28 '13 at 20:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.