Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using Windows XP with VIM 7.2, so far I've tried a bunch of different 7.2.x patch level versions (the official 7.2, and newer patched distributions from the 'Cream' project, without Cream, of course) all with same results.

After loading a file, during regular vim usage, I'm getting random flicker flashes, really short, sometimes barely noticeable, really frequent (every 4 to 20 seconds).

Some hints:

  • It does not happen with syntax highlighting disabled

  • It does not seem to be triggered for anything I do, at least directly, as sometimes just leaving vim idle (even out of focus) is enough to allow the issue to be seen.

  • At home I'm using a faster Windows Vista machine, with the same configuration settings (in sync using DropBox), the flicker is not really an issue, if you pay attention you could barely notice very quick flickers. So I think the issue might just be hidden.

  • I tried already changing "nolazyredraw", "ttyscroll=1", "nohlsearch", and similar stuff I found on the web about the issue, without luck.

Any hints?

share|improve this question

migrated from Jul 15 '10 at 17:22

This question came from our site for professional and enthusiast programmers.

This is not a hardware problem as the smart admin guys from Stackoverflow pointed out.

Here is the solution:

Seems there is some application in the background that is randomly causing my applications to refresh, with a frequency way above normal (as you notticed the flickering can be seen even or your fast compueter).

Without the patch, the editing area is automatically invalidated when such events happened, causing it to be erased (this happens really quickly), the patch causes the editing area to remain when redrawing happens.

share|improve this answer

What are the specs of your computer? I use Vim7.2 on Windows XP every day, without flickering. I DID notice that the flickering occurred on older/slower hardware, but my current work machine handles it without a sweat: 2.2Ghz dual core cpu, 2g ram, and some low end Nvidia Quaddro FX video card.

Since my rep's not high enough to comment, my official answer is: "Get a faster computer" (I know, not very helpful)

share|improve this answer

I had the same issue. As described: It would not flicker with :syntax off but flickered rather randomly with :syntax on. I found by setting :filetype off the flickering stopped. I don't really understand it but I the result was like flipping a light switch for me. Give it a try and let me know, if anyone else knows why this worked, please fill me in.

File: ~/.vimrc filetype off filetype plugin indent on syntax on

share|improve this answer

You must log in to answer this question.