Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a (as it seems to me) strange problem with my DVD burner (Sony AD7540A) which I would like to use as master device on a IDE bus. There is a HDD on the bus as well that should be (is) the slave device. This is a Hitachi Deskstar 7k250. I would like to boot from CD/DVD when a disk is inserted in the DVD drive and from HDD if no disk is in the drive (this, I believe, is very common).

The strange thing is that as soon as I connect (i.e. plug in) the DVD drive it becomes the only bootable device. When no disc is in the drive I get the "no operating system"-thing. If there is a (bootable) disc in the drive the machine boots from the disc. If I, without changing anything else, connect another drive (CD or DVD, but not burners; e.g. Hitachi GD-S200 or Acer 652P) everything works as expected.

Could that have something to do with the drive being a burner? I am at a loss...

Ps.: I am not sure if this question would be better suited for supersuser.com. But as I do not completely understand the difference between serverfault and superuser and I currently do not have an account on superuser.com I decided to ask here...

share|improve this question

migrated from serverfault.com Jul 16 '10 at 11:18

This question came from our site for professional system and network administrators.

    
This question is more appropriate for, and more likely to answered on, our sister site superuser.com. If you read our FAQ this should clear up any outstanding doubts you may have. –  Chopper3 Jul 16 '10 at 11:18
    
@Chopper3: thanks. After reading the FAQs for the gazillionth time (exaggerating a bit) I finally saw what I was looking for. serverfault: desktop PCs (other than your own); superuser: hardware. I should have known that things on SO & Co. are more easy to find than on other sites in the net (i.e. on top, not "buried" somewhere below a lot of - hmm - crap). I presumably really just overlooked this a few times. Sorry. –  scherand Jul 16 '10 at 11:47
add comment

2 Answers

up vote 1 down vote accepted

Are you 100% sure that the devices are each set to Master / Slave and not Cable-select or similar? Also ensure that there isn't a setting for "Master with no slave" on the Sony.

There's not much info on that Sony link unfortunately.

Edit

The AD-7540A appears to be a notebook drive. As such it wouldn't surprise me if it's untested with a HDD slave since laptops are very unlikely to have 3 harddrives (which is why you'd usually end up using secondary channel slave for a HDD). I'd put this down to a firmware bug (or 'feature' in the Sony drive)

share|improve this answer
    
I cannot see any way (jumper?) on the Sony drive (or the Hitachi) to set it as master (or slave or cable select or whatever). There is a jumper on the Acer drive I tested and that jumper there is set to "master". I did not change anything on the HDD between "does not work (Sony)" and "does work (Hitachi or Acer)"... The HDD is set to slave to the best of my knowledge. –  scherand Jul 16 '10 at 10:29
    
The AD-7540A appears to be a notebook drive. As such it wouldn't surprise me if it's untested with a HDD slave since laptops are very unlikely to have 3 harddrives (which is why you'd usually end up using secondary channel slave for a HDD). I'd put this down to a firmware bug (or 'feature' in the Sony drive) –  Joel Mansford Jul 16 '10 at 16:37
    
Hmm - you seem to be right; I am sure this is a feature :) I found the following page: Liggys und Dees veränderte NEC und Optiarc Firmwares that seems to have lots of resources for Optiarc drives. As I do not have a DOS box available (at least not where I can plug that slimline drive in) I cannot try their bootcode flasher which might otherwise be able to help... Thanks for your effort! –  scherand Jul 17 '10 at 17:04
    
Try freedos - I believe they have a bootable ISO you can use. Just put the flasher on a FAT USB drive and you should be able to access it having booted the FreeDOS disc. –  Joel Mansford Jul 21 '10 at 23:14
add comment

I'm pretty sure that you can't boot from an HDD that's set as an IDE Slave. You'll need to set the HDD as Master in order to boot from it. As far as booting from the CD is concerned, set the CD drive as the first boot device in the BIOS and whenever you have a bootable CD in the drive and start the computer it should boot to the CD.

share|improve this answer
    
I am pretty sure it is possible to boot from a IDE slave HDD; because it works if I use another CD/DVD-drive (without changing anything on the HDD, i.e. without setting it to master). Also I tried it the other way around (HDD as master, DVD as slave): things got worse. Also I read if a CD drive and a HDD are on the same IDE bus, the HDD should be slave: FAQ nr. 2 on Howto... Connecting IDE Hard Drives. The BIOS setting should be OK (CD drive first boot device, HDD second); also mainly because it works with another drive :( –  scherand Jul 16 '10 at 11:31
    
Some really ancient computers can't handle booting from a IDE slave (circa 386/486 days). It's more likely the CD-ROM can't handle having an HD Slave or the BIOS is configured incorrectly. CD-ROMs use ATAPI, which is SCSI over ATA buss, and the older ones didn't implement much of the ATA bus protocol. –  Chris S Jul 16 '10 at 13:22
    
-1 you should be able to boot from any IDE device providing the system bios supports it - which according to the OP this one can. –  Joel Mansford Jul 16 '10 at 17:01
    
I have seen instances where you can't boot with an optical drive master and HDD slave where the problem was actually a conflict with the controller on the optical drive. (EDIT: Unless it's hurting the throughput on the HDD that badly.) I can think of no practical reason not to make the HDD master. –  Shinrai Jul 28 '10 at 19:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.