Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

First i had a problem that i can't find hibernate in the start menu, but i did what's in this article: http://www.howtogeek.com/howto/7564/how-to-manage-hibernate-mode-in-windows-7/ and its now showing, my problem now is when i press on the hibernate button is make something like standby not hibernate and the pc keeps running just the monitor shut down and the user login screen appear when i move the mouse.

What should i do to fix that?

share|improve this question

1 Answer 1

up vote 3 down vote accepted

It might be that some device doesn't want to hibernate.

Under Win7 you can use the powercfg command to analyze such problems, See:
Evaluate System Energy Usage and Get Power Management Report with PowerCfg -Energy Switch in Windows 7

I also recommend going through these articles:

Sleep and hibernation: frequently asked questions
Troubleshooting Windows 7 Sleep Problems

EDIT

Hibernate is not done in the RAM, so 2 GB or 4 do not matter. What matters is if there is enough contiguous free space on your system disk to allocate the hibernation file hiberfil.sys. If there isn't enough space, then the file won't be allocated and hibernation won't be available. In your case, 2 GB of available disk-space are required, as this file basically contains an image of the RAM. In addition, it's advisable to have at least 1 GB of free space at all times.

I suggest that you regard in the root of your C: drive if the file exists. As this is a hidden system file, see this article : How to view hidden files, folders and extension for known file types on Windows 7, Vista and XP.

If the file doesn't exists, then try to turn hibernation on. Else turn hibernation off, ensure that you have at least 3 GB of free space, defrag the system drive, then turn it back on again and watch for error messages. The way to turn hibernation off or on is by opening the command shell with administrator rights and typing:

powercfg -H off
powercfg -H on

If nothing helps, I suggest that you post somewhere the file that is produced by "PowerCfg -ENERGY >file.txt" so that we could have a look at it.

share|improve this answer
    
nothing of those articles solved my problem, seams that i have RAM less than what windows need to hibernate, i have 2 GB ram. –  Amr ElGarhy Jul 17 '10 at 21:05
    
@Amr ElGarhy: See my edit. –  harrymc Jul 18 '10 at 6:24
    
you can access the file there amrelgarhy.com/downloads/energy-report.html , hope it helps. –  Amr ElGarhy Jul 18 '10 at 20:57
    
@Amr ElGarhy: Will look at it further tomorrow, but first look is that a USB device refuses to sleep. Check in the Device Manager all USB Root Hubs, Properties, Power Management tab "Allow the computer to turn off..". –  harrymc Jul 18 '10 at 21:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.