Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Whenever I try to start my VM in VirtualBox I get this error:

enter image description here

I tried rebooting my system and I still get the error. I didn't start any other VM programs.

I also have VMware Workstation installed on my computer which runs without problems.

share|improve this question

migrated from stackoverflow.com Jul 16 '10 at 13:17

This question came from our site for professional and enthusiast programmers.

    
Why are people saying this should be closed? –  Phenom Jul 16 '10 at 13:13
    
@Phenom, probably because it's not so much a programming question as an application support question. The votes are all to shift it accross to superuser, which is a more appropriate forum. –  paxdiablo Jul 16 '10 at 13:16
    
I was going to ask how to move it to SuperUser but I guess someone already did it for me. –  Phenom Jul 16 '10 at 13:19
    
I noticed that this problem occurs if I assign two CPU cores to the VM. If I assign only one CPU core then the problem goes away. However, I did not have this problem before using two CPU cores. –  Phenom Jul 16 '10 at 21:25

3 Answers 3

up vote 2 down vote accepted

I usually get the same error on Ubuntu, which loads the kvm kernel module automatically, which conflicts with VirtualBox.

So you have to either blacklist the kvm module (and it's implementation module, which is kvm_intel for me), or rmmod both of them before starting your virtual machine:

sudo rmmod kvm_amd kvm
share|improve this answer

This could mean that there is a lock file on disk that you need to delete. VMware Workstation has a similar warning but it allows you to start your VM if you are sure it's not used by anyone else.

share|improve this answer

This means that VMWare is currently running and using the AMD-V virutalization extensions to the CPU. You need to completely shutdown VMWare in order to launch VirtualBox with the acceleration options enabled.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.