Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am unable to install gnome-shell through Synaptic and am getting the following error. Can someone please help me out?

vmuser@vmhub:~$ sudo apt-get install gnome-shell
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  gir1.0-atk-1.0 gir1.0-clutter-1.0 gir1.0-freedesktop gir1.0-glib-2.0
  gir1.0-gtk-2.0 gir1.0-mutter-2.28 gir1.0-pango-1.0 libgirepository1.0-0
  libgjs0 libmutter-private0 mesa-utils mutter mutter-common xbase-clients
  xserver-common xserver-xephyr
Suggested packages:
  gnome-themes
The following NEW packages will be installed:
  gir1.0-atk-1.0 gir1.0-clutter-1.0 gir1.0-freedesktop gir1.0-glib-2.0
  gir1.0-gtk-2.0 gir1.0-mutter-2.28 gir1.0-pango-1.0 gnome-shell
  libgirepository1.0-0 libgjs0 libmutter-private0 mesa-utils mutter
  mutter-common xbase-clients xserver-xephyr
The following packages will be upgraded:
  xserver-common
1 upgraded, 16 newly installed, 0 to remove and 163 not upgraded.
Need to get 557kB/5,557kB of archives.
After this operation, 16.7MB of additional disk space will be used.
Do you want to continue [Y/n]? y
WARNING: The following packages cannot be authenticated!
  libgirepository1.0-0 gir1.0-glib-2.0 gir1.0-atk-1.0 gir1.0-freedesktop gir1.0-pango-1.0 gir1.0-clutter-1.0 gir1.0-gtk-2.0 gir1.0-mutter-2.28 mutter-common libmutter-private0 xbase-clients xserver-common
  xserver-xephyr libgjs0 mutter mesa-utils gnome-shell
Install these packages without verification [y/N]? y
Err http://us.archive.ubuntu.com/ubuntu/ lucid-updates/main gir1.0-gtk-2.0 2.20.1-0ubuntu1
  404  Not Found
Failed to fetch http://us.archive.ubuntu.com/ubuntu/pool/main/g/gtk+2.0/gir1.0-gtk-2.0_2.20.1-0ubuntu1_i386.deb  404  Not Found
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
share|improve this question
add comment

1 Answer

up vote 3 down vote accepted

You are trying to install version 2.20.1-0ubuntu1 of gir1.0-gtk-2.0 but the current version in lucid-updates is 2.20.1-0ubuntu2

Run sudo apt-get update and try again.

share|improve this answer
    
Awesome... Works perfectly fine! Thanks a lot... –  Legend Jul 16 '10 at 18:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.