Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The Short Version:

After using an external disk as a Time Machine target, disk permissions are forever and always utterly ignored which causes huge problems when said disk is supposed to share publicly and privately accessible files/folders over the local network.

Said disk is no longer used for Time Machine, but permissions still refuse to work after the "Ignore ownership..." option is disabled, ACL's are cleared, and more.

Anybody knows how to fix this?

The Long Version:

So, I'm trying to share some folders off of an external disk I temporarily used for a week as a Time Machine backup disk.

Because I have both "public", and private documents on the disk, I need to use disk permissions, to disallow access to some folders. Enabling file sharing works great, except any and every user get full read/write access to everything.

I have another external aswell, which is identical, just it's never been used as a Time Machine target volume, and permissions are obeyed perfectly.

Originally I think the Ignore ownership option was enabled, but the checkbox wasn't showing up on the Get Info panel. After some messing around, I realized it's not displayed if there's a folder called "Backups.backupdb" on the root of the disk.

Now, a few hours later, after renaming "Backups.backupdb" to "Backups.backupdb_OLD", clearing ACL permissions from the disk, unmounting, mounting, restarting file sharing, and lots more, IT STILL IGNORES ANY AND ALL PERMISSIONS?!

Is there some kinda super secret disk flag option or something I'm missing which causes OSX to still ignore permissions no matter what?

I hope someone here knows what's going on, 2 hours of Googling hasn't helped at all.

P.S.

I've also posted this same problem/question in Apple's Support Forums here.

UPDATE I seem to have gotten file sharing to obey the permissions, to some degree. It included removing the share from system preferences, using TinkerTool System to change the permissions to anything (didn't seem to work via normal Finder, as I'd already tried that), and then adding the volume back in sharing preferences.

This doesn't really seem very reliable tho, so I'm hoping someone can come with a technical reason/solution for this.

share|improve this question

migrated from stackoverflow.com Jul 16 '10 at 18:43

This question came from our site for professional and enthusiast programmers.

add comment

1 Answer 1

Old unanswered qn, needs attention

Why not just recreate the partition using Disk Utility, backing up anything you want to keep on the disk?

If you really want to preserve the disk, try sudo chown -R $USER:$USER $EXTVOL, where $EXTVOL is the path to the volume.

share|improve this answer
    
That's one way of doing it. But it's not a viable option if we're talking about let's say a 1TB disk that's nearly full. Only the most hardcore of hardcore geeks would have over 1TB of free space available at any time... lol –  jimeh Jan 18 '11 at 9:47
    
@jimeh: 3Tb external drives aren't outrageously expensive. The Seagate model has Firewire 800, 7200 rpm, so it shouldn't be too slow. –  Charles Stewart Jan 18 '11 at 10:02
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.