Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Possible Duplicate:
Elevated Priviliges for Startup Applications in Vista

I have several monitor/profile apps set to run at startup (Logitech Hardware stuff) that require elevated permissions. Currently, when logging on, Vista blaocks them from running and requires my intervention to get them going.

I would like to avoid turning off UAC, since I have other users on this PC.

Is the a way to selectively allow these apps to run at startup with the required permissions?

Following added for clarity -

I have configured both applications to run at admin level, but because they are being run at startup (I believe in all cases from HKLM\Software\Microsoft\Windows\CurrentVersion\Run registry key), Vista is blocking them from running. So rather than just a popup waiting from my input to run, I get an icon in the system tray telling me that Windows has blocked these programs from running.

share|improve this question

migrated from Jul 31 '09 at 17:02

This question came from our site for system and network administrators.

marked as duplicate by TheTXI Aug 2 '09 at 1:47

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

Exact duplicate:… – BinaryMisfit Jul 31 '09 at 17:04

You can get round this problem by using Task Scheduler to run the programs at startup, as this allows you to do so with elevated permissions. See this article for full details on how to do it.

share|improve this answer
This seems like the way to go. – Hondalex Jul 30 '09 at 20:23

One way is to configure a shortcut (maybe the shortcut in the Startup directory in the start menu) to always start the program with Administrator rights:

Right click the shortcut --> Properties --> Shortcut tab --> Advanced... --> select Run as Administrator

share|improve this answer
I have them set to run as admin, but Windows is blocking them and I'm guessing that it's because they're startup apps with eleveated permissions. – Steve Brouillard Jul 30 '09 at 19:59